1 Reply Latest reply on Oct 9, 2015 4:44 AM by rpandita

    Old version of mac - want lightroom

    littlej2455

      I currently am running OS X 10.7.5. on my mac. If I purchase lightroom 5 will this work? Thank you!