9 Replies Latest reply on Oct 12, 2016 12:29 AM by JB_Metrics

    Installing ColdFusion 11 on Mac OS X El Capitan (10.11)

    johnbarrett Level 1

      Hi there,

       

      I am trying to install ColdFusion 11 using the main Apache root on the Mac. This will be using port 80, and will be the localhost on the Mac, and the file structure is -  /Library/WebServer/Documents. The first part installs fine, but the second part (The web step and accessing the ColdFusion administrator) fails.

       

      However, when I set-up ColdFusion 11 using the build in Web-Server everything goes fine.

       

      Is this a bug in El Capitan?

       

      Also, I tried to use the ws_config application to connect to port 80, but this failed too.

       

      Can somebody help in getting ColdFusion 11 installed on port 80?

       

      Thanks!

      Johnny

        • 1. Re: Installing ColdFusion 11 on Mac OS X El Capitan (10.11)
          demasso

          Nobody at Adobe to even dares to reply to this question. What a bunch of idiots.

          I'm having the same issue and every time I try Adobe's crap it's the exact same waste of time. Every time !!!

          • 2. Re: Installing ColdFusion 11 on Mac OS X El Capitan (10.11)
            Carl Von Stetten Adobe Community Professional & MVP

            Only a small number of the Adobe ColdFusion team even look at these forums.  It's mostly members of the ColdFusion community helping each other out.  So if you have a specific bug, report it here: Adobe Bug Tracker

             

            As far as OSX 10.11 compatibility, that was added with the latest update (Update 7).  So do the following:

            1. Install ColdFusion 11 (you've already done this)
            2. Don't try to connect it to a web server (so just use the built-in web server).
            3. Apply update 7.
            4. Reboot.
            5. Run the Web Server Connector tool to connect ColdFusion to Apache.

             

            Until an updated installer with Update 7 built-in is released by Adobe, this is the general process for getting ColdFusion to run on OSX 10.11.

            • 3. Re: Installing ColdFusion 11 on Mac OS X El Capitan (10.11)
              demasso Level 1

              Hello, thanks for the help.  I'll give it one last shot, wasn't aware of that, and I've been developing with ColdFusion since 1995... Yeh since version 1 that is.
              I'm wondering why don't they include the latest update in the CF installer made available for download :-\  Again, what a bunch of idiots!

               

              Edit: the instructions aren't of any help if the CF server itself can't start.  Voilà :

               

               

              Starting ColdFusion 11 server ...

              The ColdFusion 11 server is starting up and will be available shortly.

              There has been an error starting ColdFusion 11 server, please check the logs.


              Now what ?

              • 4. Re: Installing ColdFusion 11 on Mac OS X El Capitan (10.11)
                Carl Von Stetten Adobe Community Professional & MVP

                I don't think referring to the ColdFusion team as "idiots" is warranted.  Building new installers to incorporate the updates takes time.  I would expect it to happen soon.  In the meantime, the process I outlined works - and the same process works whenever they release an update to specifically add support for a new OS release.  Just like when the update was released to support Windows 10.

                 

                Developers who rush out to upgrade the OS on their machines as soon as it is released have to live with the consequences - not every piece of software will work on that new shiny OS.  While I wish Adobe was more proactive about testing on pre-release builds of new OS versions so that they can release updates/installers as the new OS launches, they have a lot of other work to do (bugfixes, new product development, etc.).  So cut them some slack.

                 

                In response to the issue you now have (ColdFusion won't start), have you tried starting it from the command line (I'm not a Mac user, so my terminology may be off).  If it starts from the command line, then try applying the update.  If it doesn't start, look at the command line output and see if there are any errors.  If there are, post them here.

                 

                -Carl V.

                • 5. Re: Installing ColdFusion 11 on Mac OS X El Capitan (10.11)
                  demasso Level 1

                  When I say "idiots", I'm not referring to the ColdFusion team, I'm referring to Adobe. They're idiots because they're not willing to put the necessary ressources to the CF team in order to ship a decent installer right away, because they prefer to put php support in dreamWeaver instead of 'simply' keeping the minimal cfml syntax support.  But that's part of another aggravation I have with Adobe.  They made me quit my beloved Dreamweaver and at the same time I'm thankful for it because it made me discover sublimeText which is just fantastic!

                  Also, Adobe f*cking up CF so much made me discover Lucee, which _is_ the future of CFML. Period.

                   

                  It has less to do with rushing to install the newest OS, it's been in beta for quite some time beforehand, I assume the CF team should have had the time to fix it, but I can only imagine how reluctant Adobe is to put the necessary ressources to keep a high level of quality in CF. Because they just want to make as much bucks from it as possible before definitely killing it some day.

                   

                  I managed to fix my CF install by the way. Thanks for you help.

                  • 6. Re: Installing ColdFusion 11 on Mac OS X El Capitan (10.11)
                    demasso Level 1

                    And if they're unable to fix the installer on time, they should at least warn their (potential) customers. But then again, who the f*ck am I to expect anything from Adobe? I miss the Macromedia era ; they, at least, knew how to take care of their customers, unlike Adobe, to them, we, customers, we're just cows which can be milked, and don't pretend that's not true.

                    • 7. Re: Installing ColdFusion 11 on Mac OS X El Capitan (10.11)
                      happysailingdude Level 1

                      @demasso - what did you do to get cf running on el capitan in the end please? (I have the same problem - having waited several months before upgrading my os specifically to try to avoid this sort of problem) Thanks very much for any help you can provide.

                       

                      Nick

                      • 8. Re: Installing ColdFusion 11 on Mac OS X El Capitan (10.11)
                        JB_Metrics Level 1

                        Okay, I have been running Mac OS X El Capitan on ColdFusion 11 fine until the upgrade today to Mac OS Sierra where I got a 404 error trying to go to http://localhost/CFIDE/Administrator/index.cfm and none of my ColdFusion pages would run the ColdFusion code on Apache2 even though it said ColdFusion was up and running as is Apache2 (with the wonderful "It Works!" page to show Apache is running).  So both ColdFusion and Apache are running fine, but not together.  What gives?

                         

                        Well the answer I soon discovered was that with upgrading to Sierra from El Capitan is that Apache has been upgraded as well.  That means the connectors between ColdFusion and Apache have been broken and no longer work!

                         

                        The solution I found was a mix of a couple different solutions and probably most were not necessary, but what is necessary is removing the existing connectors and reestablishing a new connection between ColdFusion and Apache using wsconfig (/Applications/ColdFusion11/cfusion/runtime/bin/wsconfig).

                         

                        1. Stop Apache2 (sudo apachectl stop), stop Coldfusion (./coldfusion stop - run from /Applications/ColdFusion11/cfusion/bin directory)

                         

                        2. Delete /Applications/ColdFusion11/config/wsconfig/1 directory  (you may need to give yourself write permission first and I found it necessary to give Read & Write temporarily to 'Everyone' for the wsconfig folder and all content and subfolders contained within.

                         

                        3. I had to go into /etc and Get Info on Apache2, unlock and then temporarily give 'Everyone' Read & Write privileges. Start Apache.

                         

                        4. Run wsconfig and navigate to select /etc/Apache2 folder (it doesn't select the folder and left it blank, but I was able to quickly click on Advanced and exit, at which point the /etc/Apache2 folder was displaying correct (bug in wsconfig tool) and then applied the configuration.

                         

                        5. Start ColdFusion and enjoy ColdFusion 11 working on Mac OS Sierra.

                        • 9. Re: Installing ColdFusion 11 on Mac OS X El Capitan (10.11)
                          JB_Metrics Level 1

                          UPDATE:  I found another glitch when I tried to test some of my Flex Web Apps.  When I had to deal with the new Apache 2 that comes with OS Sierra, I decided to bite the bullet and use virtual hosts.  This immediately caused flex2gateway errors for all three virtual hosted sites (that used to work under folders under localhost - which always meant in testing I had to go down subfolders in the URL).  I setup the Virtual Host as explained in the Apache documentation but still had problems until I found an article talking about multiple instances (and multiple virtual hosts).

                           

                          Thankfully, that article (Zero'd Out: Configuring ColdFusion 2016 Server Instances to Different Virtual Hosts (Multi-Homing)) gave me the solution to solve a different error I had when I migrated from Apache running sites on /Library/WebServer/Documents to /Users/{Username}/Sites/test and used Virtual Hosts. I immediately got:

                           

                          "Channel.Connect.Failed error NetConnection.Call.Failed: HTTP: Status 404: url: 'http://test.dev/flex2gateway/'"

                           

                          The one line I was missing from the /etc/apache2/extra/hhtpd-vhosts.conf virtual host groups was: JkMountFile "/Applications/ColdFusion11/config/wsconfig/1/uriworkermap.properties"

                           

                          Although I wasn't going for multiple instances, this solved my flex2gateway error.

                           

                          (I just wish I had found the article 3 hours earlier).