5 Replies Latest reply on Nov 30, 2006 2:33 PM by Swiggles

    Fatal application error  - HELP!!!

    Swiggles Level 1
      Hi,

      Fatal application error requesting that I close "one or more programs to increase available memory and try again". I have no other programs running. I tried this twice and even rebooted my PC without luck. I last compiled (for chm) this project in October without problems (size ~5.5 MB). All I did was add some text to an existing topic page. No changes were made to my PC.

      My PC:

      P4 3GHz
      1 GB RAM
      ~25 GB free HD Space
      Win XP Pro SP 1
      RoboHelp X5.0.1 Build 606
      Size of project is ~85 MB

      Task Manager reported that I was using ~391 MB of RAM before this error. CPU useage never got above 55% My smaller projects compile just fine. Any ideas why this is happening?

      Thanks,

      DaLy

      PS: Tomorrow I will see if my Oct backup of this project compiles without a problem (it did in Oct). Even if it does compile, I would still like to know why adding a few lines of text to an existing topic page would cause this crash. I didn't think there was a size limit. Also both projects (the current and the backup) are almost the same size.
        • 1. Re: Fatal application error  - HELP!!!
          Level 2
          Hi,

          I can't tell you why you ran into this, but I have seen this happen with RoboHelp and other applications. It seems to be that the resources are not being cleaned up. Have you tried rebooting the computer and reloading the project? That usually does the trick.

          John
          • 2. Re: Fatal application error  - HELP!!!
            Swiggles Level 1
            Hi John,

            Rebooting my PC did not work. However, when I used my back up copy (I back up after each change that I make to a project), added my new text, and generated my chm file, it worked fine. I would still like to know what caused this error. Could the .xpj file have become corrupt somehow when I added my new text?

            Thanks for your reply,

            DaLy
            • 3. Re: Fatal application error  - HELP!!!
              Swiggles Level 1
              Hi,

              Today, I added 4 more (small) topic pages and 4 gif images (all under 3k) to this project that compiled fine yesterday. Same problem/error today. Tried rebooting, full shut down, disabling Norton, and disconnecting my PC from our network. Nothing else is running on my PC (checked and double checked) - just RoboHelp.

              I could really use some help to fix this problem.

              Thanks,

              DaLy
              • 4. Re: Fatal application error  - HELP!!!
                Peter Grainge Adobe Community Professional (Moderator)
                There's a topic on my site about opening projects and that covers deleting the cpd and xpj files. Take a look at that. As the copy worked OK, it does seem likely that the file you are working with does have a problem that this might fix. I am assuming no network is involved here.

                • 5. Re: Fatal application error  - HELP!!!
                  Swiggles Level 1
                  Hi Peter,

                  Thanks for your reply. I will take a look at your this topic on your site. Since I back up all of my "good" projects (everytime I make a change) , I will probably not recreate the xpj file or cpd file of a "bad" project.

                  I just finished creating a successful chm. I replaced my 4 GIFs (of tables created with Word) with tables created in RH. I don't think that four 3k GIFs (created with MS Paint) would cause this problem, but one never knows. I also did not make templates of these 4 topic pages, and I did not run the Index Wizard as before. I put a copy of this "good" project in my backup directory, so I'll have a good xpj file and a good cpd file should this problem happen again

                  Later today, I will use Window's Error checking tool and than defrag my HD, in hopes that the problem will not occur in the future
                  Have a great afternoon,

                  DaLy

                  PS: Since this is not a "known problem" directly related to RH. I'm marking this ticket closed. Gosh, this might be a Windows problems.