10 Replies Latest reply on Oct 24, 2015 2:59 PM by socalemc

    AE 2015 Hangs on Initializing MediaCore

    Dave Bode

      After Effects 13.5.1 hangs on launch for about at least 7 minutes (probably more). It looks like it is stuck on Initializing MediaCore.

       

      I have searched a bit on the subject and I have gone into the firewall and enabled all of the .exe files for the current version of AE. There because I have used this system through several versions of AE there are several versions of many of those files. I assume that AE 2015 only needs to have those exe files enabled in the firewall that are in the 2015 folders (for AE and Premiere), correct?

       

      I also read that I need to "Remove all third-party QuickTime importers and exporters from the Library/QuickTime directory and restart the application." A quick search on Library/QuickTime directory indicates that this is a Mac file/folder location. I searched for a QuickTime folder in Program Files and I couldn't find anything relent.

       

      This issue has come up in the last week and Premiere Pro is also hanging in the same way, although I don't see an Initializing MediaCode readout in the Premiere Pro launch window. It just has the hiker/Daniel Son pre-crane kick pose guy.

       

      The only change to my system that I made recently was that I pointed Premiere Pro to some new 3-rd party audio plugs. When I did so, Premiere worked just fine for days. I use AE for projects about 40-60 hours a week, so this sucks.

       

      My system:

      Win 7 64bit (up to date)

      i7 970

      24GB Ram

      NVIDIA 970GTX (driver up to date)

      500GB SSD

      2TB internal

      2 x 4TB internal

      3TB internal

      16TB RAID 5 via USB 3.0

      USB 2.0 and 3.0 drives

      FireWire audio device (M-AUDIO FireWire1814)... although, I am not using it for playback. It is connected.

       

      What shall I try next? I have not updated AE to the latest version because it looks like the only change is photo raw. I am hesitant to update since the CC 2015 update/nightmare.

        • 1. Re: AE 2015 Hangs on Initializing MediaCore
          Dave LaRonde Level 6

          Sad to say, you didn't avoid the AE CC 2015 nightmare.  You're running it... or trying to.  You probably need to install AE CC 2014 because when you ran what you thought was an update was the new version... and the new version deletes the previous versions!

           

          Wasn't that thoughtful of Adobe?

          • 2. Re: AE 2015 Hangs on Initializing MediaCore
            Dave Bode Level 1

            Update: AME (Adobe Media Encoder) is also hanging on launch. It only took 20 minutes to open.

             

            I am going to install CC 2014 and see how that goes.

            • 3. Re: AE 2015 Hangs on Initializing MediaCore
              socalemc Level 1

              Same issue. The most recent updates have brought my workflow to a total standstill.  Premiere, Encoder, Prelude and After Effects were all hanging up.  For the first three, I removed ExporterAVI.prm and solved the problem but After Effects is still hanging up and I have tried all recommended fixes. I have not installed anything new except Adobe updates over the last week.  I let AE sit for nearly an hour and it remained hanging up, never opening.  I have now spent two totally unproductive days trying to resolve the issue. Very frustrating.

               

              Win 10

              32GB Ram

              i7 970

              Nvidia 970GTX

              • 4. Re: AE 2015 Hangs on Initializing MediaCore
                Dave Bode Level 1

                socalemc, we are both i7 970 users with GTX 970 cards. Nice! Maybe it is something with our particular hardware? I have the ASUS STRIX GTX 970.

                 

                Where did you remove ExporterAVI.prm from? And what does it do? I actually use a Lagarith lossless codex in AVI all the time for exports.

                 

                Thanks for responding to the post!

                • 5. Re: AE 2015 Hangs on Initializing MediaCore
                  socalemc Level 1

                  Is there any chance you did a Nvidia update recently? I wonder if there was an update that I didn't notice.  I do not know what ExporterAVI.prm actually does but Premiere, AME and Prelude all seem to be working fine without it now.  This was a solution I found from other message boards.  It is in the plugins/common folder for each app, except After Effects.

                   

                  Adobe After Effects, however, is still not working.  I just read on another message board where Matrox VFW software codec has been causing hangups and I do have this installed since I used to use some Matrox hardware.  I'll try removing this codec later today to see what happens.


                  With After Effects, I am continually hanging up on "Loading MediaCore" and any solution would be awesome at this point.  I am now having to work from two different work stations which is not ideal.


                  I hope we can get this resolved!

                  • 6. Re: AE 2015 Hangs on Initializing MediaCore
                    socalemc Level 1

                    Resolved. It looks like the Matrox VFW codec was the culprit. 

                     

                    All Creative Cloud apps are working just fine after I removed that.  I'll have to see if Matrox has updated it, not that I need it often, but I have some old files that use Matrox codecs.

                    • 7. Re: AE 2015 Hangs on Initializing MediaCore
                      Dave Bode Level 1

                      Instead of removing the .prm files, I tried renaming them. Sadly, renaming the ExportAVI.prm files to ExportAVI.old_prm didn't help. Premiere, AE, and AME still take 10-20 minutes to launch.

                       

                      I just bought a new notebook for a workshop I am teaching and all CC apps launch just fine. I am afraid I may have to do some serious reinstalling. Some day I will do a full system rebuild, but with 175GB of applications installed it might be easier to wait to hit the lottery.

                       

                      Adobe gurus, please give me wisdom to help my system along a little longer!

                       

                      Thanks!

                      • 8. Re: AE 2015 Hangs on Initializing MediaCore
                        socalemc Level 1

                        Did you try removing them just to check? I have read on other message boards noting that renaming won't do the trick.  For me it was a combination of those .prm files for three programs and the Matrox codec for After Effects.  I have since re-installed all other applications and things are still working fine. 

                         

                        I have also read that the hang ups could be due to a Quicktime 3rd party plug-in incompatibility, so if you installed anything that might use Quicktime, that might be worth looking at too. I'll check back as I am very curious what your solution is as well.

                        • 9. Re: AE 2015 Hangs on Initializing MediaCore
                          Dave Bode Level 1

                          I think I have solved it. I don't know what exactly fixed it, but I updated my GTX 970 driver and Premiere and AE fired right up.

                           

                          The problem did manifest when I updated to the previous driver version, it was some time after that.

                           

                          It's fixed now. That's all I care about!

                          • 10. Re: AE 2015 Hangs on Initializing MediaCore
                            socalemc Level 1

                            Great to hear that you resolved this.  We now have two more solutions for the same problem.  Hopefully this thread will help others too!