11 Replies Latest reply on Jan 31, 2012 1:57 PM by symmetricalMan

    Image Hyperlink Problems

    Mikel_Anne
      I just inherited a help file after a coworker was laid off. There are TONS of broken links. They all seem to be links that are "supposed" to popup images. The images (jpg, gif, png) are all available in the Project Manager. However, when I Insert Hyperlink, the images are not visable in the Select Destination section of the window. According to RoboHelp online help, these image files "should" be available.

      Any ideas what I'm doing wrong?
        • 1. Re: Image Hyperlink Problems
          RoboColum(n) Level 5
          Hi Mikel Anne and welcome to the RH community.

          Do the images have a red "X" through the icon in the Project Manager? If so, it looks like they have been renamed or moved outside of RH. In these instances RH does not know where they are. If you right click on the image and select Properties, then click on the File tab and click the Open Folder button, are the files in there?
          • 2. Re: Image Hyperlink Problems
            Mikel_Anne Level 1
            Just checked. No red X's and the files are there. However, it appears that the .png format is unsupported which really surprises me.
            • 3. Re: Image Hyperlink Problems
              RoboColum(n) Level 5
              Can you insert a png file. What makes you think they are unsupported?
              • 4. Re: Image Hyperlink Problems
                Mikel_Anne Level 1
                Hi Colum,
                When I right-click on the .png files and bring up Properties, the General tab displays "File format not supported."
                • 5. Re: Image Hyperlink Problems
                  RoboColum(n) Level 5
                  Don't worry aout that. If you open the links to the images and navigate to the relevant file this will hopefully reinstate the link correctly.
                  • 6. Re: Image Hyperlink Problems
                    symmetricalMan Level 1

                    Hi there.

                    Was this ever resolved, because I believe I've encountered the same problem?...

                     

                    Here's what I'm attempting to do:

                    I have RH 8.0.2.208

                    I have selected some text in my topic that I wish to add a hyperlink to (specifically a popup), such that when the user clicks on the link, a small popup will appear that contains nothing but an image of a button. Example text might read: Click the Export button to open the Export window...

                     

                    Now, I've successfully done this by first creating a separate topic called 'Export Button', and adding the Export button image to this topic. Then I simply link the original text to a popup of the Export Button topic (which is set to auto-resize). No problem, it works.

                     

                    However, it occurred to me that what I might be able to do is link directly to the button image itself, and in this way eliminate the need to create a separate topic for each and every button image I have (hundreds of them).

                     

                    So, again I selected the 'Export button' text within my sentence, and clicked the 'Insert Hyperlink' button. This time though, instead of locating the topic that contains the button image, I used the 'Select Destination (file or URL)' drop-down selector to switch from 'Topics' (the default selection) to 'Images', hoping that I would then see a list of all the images assigned to my project. But the list is empty. Even if by using Robohelp's Project Manager I manually drag image files into the Images folder, that list within the 'Select Destination (file or URL)' option remains empty. Furthermore, if I select the 'All Folders' option, no images appear there either.

                     

                    I have a feeling that it's simply not possible to create a popup of an image (you have to create a popup of a topic, that contains the image).

                    • 7. Re: Image Hyperlink Problems
                      Peter Grainge Adobe Community Professional (Moderator)

                      Let's get this clear.

                       

                      Your topic will have text Click the XXX Button to do something and you want XXX Button to be a link that when clicked displays an image of the button, correct?

                       

                      First of all to get the image into the project it has got to appear in at least one topic so that might as well be your popup.

                       

                      Second, even if you do create all those topics and then in the topic with Click the XXX Button to do something and create a link direct to the image, when the user clicks that link, it they will see only that link and have to click the Back button to get back to the help topic. With a popup, they just click outside the popup and all the time they can see the topic they were reading. Much more user friendly.

                       


                      See www.grainge.org for RoboHelp and Authoring tips

                       

                      @petergrainge

                      • 8. Re: Image Hyperlink Problems
                        symmetricalMan Level 1

                        Hi Peter,

                         

                        Yes, what you've described is exactly how I have it working already; each image is in a topic of its own, the links within the content topics link to those image-topics as popups, and the user just clicks outside the popup to close it.

                         

                        Is it possible to create a link that links directly to an image file, and displays that image as a popup, without having to embed that image in a topic first?

                        • 9. Re: Image Hyperlink Problems
                          Peter Grainge Adobe Community Professional (Moderator)

                          Is it possible to create a link that links directly to an image file, and displays that image as a popup, without having to embed that image in a topic first?

                           

                          Please see my previous answer "First of all to get the image into the project it has got to appear in at least one topic so that might as well be your popup."

                           

                          How do you propose to get the images into Project Manager so that you can create links to the images?

                           

                          The only ways to get an image into Project Manager is by putting it into a topic (which includes popups) or as a baggage file. If you create a link to an image baggage file it seems to replace the link text with the image.

                           


                          See www.grainge.org for RoboHelp and Authoring tips

                           

                          @petergrainge

                          • 10. Re: Image Hyperlink Problems
                            Peter Grainge Adobe Community Professional (Moderator)

                            I have been reminded of something that I thought had been fixed. Whilst it will enable you to get a popup of the image, it is still not likely to be acceptable.

                             

                            Select some text and then go to the image in baggage files. Press the shift key and then drag the image to the selected text.

                             

                            Then double click the text and change the link to a popup. In Preview it will likely error but it will sort of work in webhelp.

                             

                            For small images the popup will be too large. I hear you say "use a custom size popup". I found that resized the small image, not the popup.

                             

                            For large images they get resized down.

                             

                            Seems to me whichever way you turn, the answer is more work (you have to add the images as baggage files unless you have them in topics somewhere) and the results are not ideal. I also found I didn't like the way the text moved when first clicking a popup in the generated help.

                             


                            See www.grainge.org for RoboHelp and Authoring tips

                             

                            @petergrainge

                            • 11. Re: Image Hyperlink Problems
                              symmetricalMan Level 1

                              Thanks Peter,

                               

                              Your suggestion re using baggage files works perfectly, and I don't get any errors in preview, nor do I get any problems with using custom popup sizes. Perhaps this is because I'm generating a CHM? In any case, it seems to be working as I'd hoped.

                               

                              Also... I then tried the "shift-key-drag" technique you described using an image from the Images folder itself (not via the Baggage folder), and it works too.