4 Replies Latest reply on Oct 25, 2015 1:36 PM by ManiacJoe

    "This Catalog is too new for this version of LR"

    kailapehl

      Trying to open a LrCat and it's giving me "this catalog is too new for this version of LR" I tried updating through CC, I tried uninstalling and then reinstalling and it's still giving me the same error. What do i do?