0 Replies Latest reply on Mar 30, 2009 7:05 AM by mpavas

    asdoc -exclude-classes

      Hello,
      I get the following error while i try to generate documents with asdoc for a full "rc"project in flex. Version.cs in flex plugin folder creates an issue. Please guide me or direct me to a proper forum. I have tried enoughf but no solution for the below problem.

      The error:
      D:\Program Files\Adobe\Flex Builder 3 Plug-in\sdks\3.2.0\frameworks\projects\airframework\src \mx\core\Version.as(18): col: 13 Error: The static attribute may be used only on definitions inside a class.

      mx_internal static const VERSION:String = "3.2.0.3958";

      - I tried to include the below line but no help.
      -exclude-classes "D:\Program Files\Adobe\Flex Builder 3 Plug-in\sdks\3.2.0\frameworks\projects\airframework\src \mx\core\Version.as"

      The entire command is as below.
      asdoc -source-path D:\FlexWorkSpace\components -doc-sources D:\FlexWorkSpace\comp
      D:\FlexWorkSpace\FlexLib "D:\Program Files\Adobe\Flex Builder 3 Plug-in\sdks\3.2.0\frameworks\projects\airframework\src " -exclude-classes "D:\Program Files\Adobe\Flex Builder 3 Plug-in\sdks\3.2.0\frameworks\projects\airframework\src \mx\core\Version.as"
      -main-title "My AIR API Documentation" -window-title "My AIR API Documentation" -output C:\asdoc_temp

      Please help.