3 Replies Latest reply on Nov 18, 2015 3:06 PM by loveAndPeace

    Export >Reflowable ePub.  Master pages formatting is not visible.

    loveAndPeace

      Adobe.com technical support  has escalated a couple of my questions and I am waiting to here back.

      The following is one of them.

      If I use a 'fixed layout' and export to ibooks, the hyperlinks are Not Clickable.

      They are working on that.

       

      So I am now exporting the 'reflowable' epub format.

      Now the Master Page which has the Title and Author is Not showing up in ibooks.

       

      Is there a way to make certain that this functionality is exported ?

       

      4 years ago, I created an ebook and the hyperlinks are clickable and the Title and Author are on the top of each page.

      What happened ?

       

      Thanks

       

       


        • 1. Re: Export >Reflowable ePub.  Master pages formatting is not visible.
          Steve Werner Adobe Community Professional & MVP

          It's the nature of Reflowable EPUB, that the Master Page items will not be written into the EPUB file.

           

          This has been true since InDesign started supporting export to EPUB. I have exported EPUB in CS5, CS 5.5, CS6, and CC, and that hasn't changed.

           

          The reason is that with reflowable EPUB, the size of the type and how the lines break will vary depending on the particular format of the eReader, and the font size determined by the reader.

          1 person found this helpful
          • 2. Re: Export >Reflowable ePub.  Master pages formatting is not visible.
            Cari Jansen Adobe Community Professional

            Hyperlinks in EPUB should work for both Fixed Layout and Reflowable EPUB export.

             

            How are you creating the Hyperlinks? Try the following:

            1. Select the text that needs to become the hyperlink.
            2. Choose New Hyperlink from the Hyperlink panel menu.
            3. Set the Link To option to URL in the New Hyperlink panel, and enter the full URL under Destination. E.g. http://www.adobe.com
            4. Click OK.


            If you can't get it working:

            • Do none of the hyperlinks work, or just some?
            • Are you able to provide more information/screenshots of the steps you are using to create them, and the type of Hyperlinks you are creating.
            • What's the source of the hyperlink? How are you selecting the destination?
            • Does the URL you are using contain any special characters, or sub-directories? e.g. http://www.adobe.com/products/page-1.html


            Also what version of InDesign CC are you using?

            • (Win) choose Help > About InDesign or (Mac) InDesign CC  > About InDesign
            • The version is listed below the Adobe InDesign CC text

             

            Also as Steve mentions...  Master Items will only appear on EPUB pages, when you export to EPUB (Fixed Layout), but not for EPUB (Reflowable).

            • 3. Re: Export >Reflowable ePub.  Master pages formatting is not visible.
              loveAndPeace Level 1

              Hi Cari (and Steve)

               

              I have been working on this issue (and others) which are now fixed. 

               

              Indesign CC 2014

              ibooks 1.2 (825)

               

              My hyperlinks within my text work fine.

              select the text > right click > hyperlink > new hyperlink > url

              url: http://www.exampleWebsite.com

               

              My Most important ISSUE. 

              I have hyperlinks inside of my footnotes. 

              These worked for my other book published in 2010 and I cannot get it to work now.

               

              Thanks again,

               

              My other ISSUE.

              I have maps and chess boards .tiff in the back of my book.

              I have footnotes.

              In the footnotes I have 'textToDescribeMap'

               

              select the text > right click > hyperlink > new hyperlink > page

              page: 256

               

              This does NOT work.

               

               

              indesignHyperlinksInFootnotes.png