10 Replies Latest reply on May 22, 2006 10:14 AM by mikiM

    Cannot run the samples in Flex Builde beta 3

    mikiM Level 1
      The installation of Flex Builder finished OK. I did choose to install Flash 9.0 in both IE and FF, but for some reason when going to the examples it asks me to install Flesh 8.0. Even if I say yes to th eprompt it doesn't display.
      I have even re-installed the flas Active X manually and even regieterd it as per instructions on the Installation of Flex Builder 2.0 beta 3 page,, but still no luck...

      Any help is appreciated.

      Thanks
        • 1. Re: Cannot run the samples in Flex Builde beta 3
          mikiM Level 1
          It seems that the problem is only in IE I have version 6 sp 2 with all the patches.
          • 2. Re: Cannot run the samples in Flex Builde beta 3
            ur_dtrain Level 1
            You need to make sure you've uninstalled your previous version before trying to upgrade. If this step is not taken installation is hit or miss.
            • 3. Re: Cannot run the samples in Flex Builde beta 3
              mikiM Level 1
              We are stuck and no idea where to go from here.
              System: Win XP Professional, sp 2 with the latest patches
              CFMX Developer Edition 7.01 with updater 1
              Clean installation of Flex Builder 2.0 beta 3, finished OK. During the installation Had selected to install the new flash player 9 for both IE (6.1) and FF (1.5)
              Flex Builder Opens OK and displays the help properly
              Clicking on any of the examples asks me if I want to install Flash 8, Even if I choose yes it doesn't display anything and if I select another example it will ask me again.

              Trying to run the same examples in directly in IE fails, but works in FF.

              Thanks

              BTW this is from the installation log

              Installation: Successful.

              484 SUCCESSES
              0 WARNINGS
              0 NONFATAL ERRORS
              0 FATAL ERRORS
              • 4. Re: Cannot run the samples in Flex Builde beta 3
                Level 7
                My guess is that something went wrong with your installation of Flash
                Player 9 in IE failed for some reason (?), and that you have IE
                configured as the default browser on your system (so that's the one that
                FB launches).

                Uninstalling/reinstalling (with IE not running) might fix the IE/Flash
                Player install.

                Changing the default browser to Firefox would be an alternative
                solution... FB would launch to Firefox instead, where the install seems
                to have worked correctly.

                Rebecca - Adobe

                mikiM wrote:
                > We are stuck and no idea where to go from here.
                > System: Win XP Professional, sp 2 with the latest patches
                > CFMX Developer Edition 7.01 with updater 1
                > Clean installation of Flex Builder 2.0 beta 3, finished OK. During the
                > installation Had selected to install the new flash player 9 for both IE (6.1)
                > and FF (1.5)
                > Flex Builder Opens OK and displays the help properly
                > Clicking on any of the examples asks me if I want to install Flash 8, Even if
                > I choose yes it doesn't display anything and if I select another example it
                > will ask me again.
                >
                > Trying to run the same examples in directly in IE fails, but works in FF.
                >
                > Thanks
                >
                > BTW this is from the installation log
                >
                > Installation: Successful.
                >
                > 484 SUCCESSES
                > 0 WARNINGS
                > 0 NONFATAL ERRORS
                > 0 FATAL ERRORS
                >
                >
                • 5. Re: Cannot run the samples in Flex Builde beta 3
                  Level 7
                  P.S. I asked Chris Agruss (our build and installer guru) about some
                  possible reasons why the Flash player installer might have failed to
                  work for IE. I've attached his reply.

                  Rebecca - Adobe

                  Here are a few cases I know about where the ActiveX plugin for FP won�t
                  be installed normally:
                  � IE is running at the time, and especially if activeX has been run
                  � Outlook, or some other program that runs the IE engine under the hood,
                  is running
                  � Older ActiveX version installed that needs some Dark Magic, or
                  explicit uninstallation of some sort

                  In the first two cases, where IE is in use, the plugin will normally be
                  installed after a reboot, but until then it will look as if the
                  installation didn�t work.

                  -ChrisAg


                  Rebecca Hyatt wrote:
                  > My guess is that something went wrong with your installation of Flash
                  > Player 9 in IE failed for some reason (?), and that you have IE
                  > configured as the default browser on your system (so that's the one that
                  > FB launches).
                  >
                  > Uninstalling/reinstalling (with IE not running) might fix the IE/Flash
                  > Player install.
                  >
                  > Changing the default browser to Firefox would be an alternative
                  > solution... FB would launch to Firefox instead, where the install seems
                  > to have worked correctly.
                  >
                  > Rebecca - Adobe
                  >
                  > mikiM wrote:
                  >
                  >> We are stuck and no idea where to go from here.
                  >> System: Win XP Professional, sp 2 with the latest patches
                  >> CFMX Developer Edition 7.01 with updater 1
                  >> Clean installation of Flex Builder 2.0 beta 3, finished OK. During
                  >> the installation Had selected to install the new flash player 9 for
                  >> both IE (6.1) and FF (1.5)
                  >> Flex Builder Opens OK and displays the help properly
                  >> Clicking on any of the examples asks me if I want to install Flash 8,
                  >> Even if I choose yes it doesn't display anything and if I select
                  >> another example it will ask me again.
                  >>
                  >> Trying to run the same examples in directly in IE fails, but works in
                  >> FF.
                  >>
                  >> Thanks
                  >>
                  >> BTW this is from the installation log
                  >>
                  >> Installation: Successful.
                  >>
                  >> 484 SUCCESSES
                  >> 0 WARNINGS
                  >> 0 NONFATAL ERRORS
                  >> 0 FATAL ERRORS
                  >>
                  >>
                  • 6. Cannot run the samples in Flex Builde beta 3
                    Larry McLister (Adobe) Adobe Employee
                    I was surprised by it as well but it is expected behaviour for pre-release flash player active-x control (even if it is confusing).

                    For security reason you need to manuall uninstall a release active-x control before installing a pre-release version of the active-x control. I beleive there is an entry in add remove programs for Flash Player 8. Close all applications and uninstalling FP via add/remove programs. Then run the pre-release Flash Player 9 installer. It can be found in [flex builder install path]\Player\debug

                    hth
                    -Larry
                    Flex Builder Team
                    • 7. Re: Cannot run the samples in Flex Builde beta 3
                      Larry McLister (Adobe) Adobe Employee
                      btw - this is mentioned in the [L=install instructions]

                      Debug players:
                      - Flex Builder 2 - C:\Program Files\Adobe\Flex Builder 2.0 Beta 3\Player\Debug directory (default location). For a plug-in installation, replace "Flex Builder 2.0 Beta 3" with "Flex Builder 2.0 Plug-in Beta 3".
                      - Flex Data Services 2 - install_root/resources/player/debug
                      - Flex SDK 2 - install_root/player/debug

                      Web players: Installers for the Web versions of Flash Player 9 and the latest Flash Player uninstallers are available from the Adobe Labs Downloads page.

                      To install the Internet Explorer ActiveX control, run one of the following executable files:
                      - Content debugger player - Install Flash Player 9 AX.exe
                      - Web player (release) - Player9_B3_AX_05-08.exe (downloaded from Adobe Labs.)

                      Tip: If you have problems getting the Flash Player ActiveX control to work, try entering the following in a command prompt: C:> regsvr32 c:\windows\system32\macromed\flash\flash9a.ocx

                      ...

                      To uninstall Flash Player from your browser, download and run the appropriate uninstaller:

                      Windows: Player9_B3_Uninstaller_05-08.exe
                      Macintosh: Player9_B3_Uninstaller_05-08.dmg
                      • 8. Re: Cannot run the samples in Flex Builde beta 3
                        mikiM Level 1
                        Well, I have replay a few days back, but some how I cannot see it.
                        So theproblem was fixed by uninstalling FlexBuilder, manually deleating all the folders, restatrting the computer and fresh install.
                        After that all seems fine.
                        I guess I may had IE open when doing the first installation.
                        All seems fine now and I can run the examples and work the tutorials.
                        One small problem though. If I run any of the examples from the tutorials from Flex Builder it runs fine. If I copy the html and swf files under the web server root and I try to run the html wrapper form there I get an error : "Expecting object" but if I run the swf file directly it runs fine. Do I miss something?

                        Thanks
                        • 9. Re: Cannot run the samples in Flex Builde beta 3
                          ur_dtrain Level 1
                          Make sure the path is correct in the object tag for your html page.
                          • 10. Re: Cannot run the samples in Flex Builde beta 3
                            mikiM Level 1
                            I found the problem. Once I copied the AC_OETags.js and history.js files it works fine

                            Thanks