2 Replies Latest reply on Oct 31, 2015 2:06 PM by Mcifuentes

    Flash frame drops on windows but not mac

    Mcifuentes

      I am trying to animate a scene of 5 people sitting at a desk, talking at 1080p resolution 24 fps. But i cant work on it since i keep getting framedrops during playback. So i decided to simplify the scene in a new document to see what is causing the problem. I tested a scene of just a person talking. No effects, nothing fancy just the torso, which is fixed, hand movement and lipsync. But when i play on time line i frames drop from 24 fps to 12, eventually to 4 fps. The psd files imported are kinda big, over 1k per image.

      (Example: body=1500 x 1500 px, top arm=1k px, lower arm=1k pixles, hand = .5k px) yes I thought about down scaling but when I tried the same document on my friends mac book laptop, it didn't have a single problem. Meaning I COULD use those sizes but something is cause my computer not to function correctly using those sizes.

       

      My primary pc is

      Windows 10, intel core i7 4770k,

      Nvidia gtx 980

      Ssd primary with 60 gb of free space

      16 gbs ripjaws memory ram

      All drivers including flash uptodate, graphics, and os

      Windows 10.

      While using flash my cpu stayed under 10% usage

      Under 25% ram memory

       

      When I open the same file on a macbook pro laptop, not once did I get a single frame drop. I tried it two different computers, windows 7 and 10, again all updated to latest drivers, and gave me same problem. Frame drops 24 to 12 and sometimes to 6 fps.


      I'll explain step by step. SInce I was having so many problems I decided to split the project into sections. I would start doing only lipsync. start new document 24 fps 1980 x1080p web_gl, also tried it in html 5 canvas same thing. Imported two images, head and a mouth, both psd in to two different layers. Head is1k and mouth is .5k in pixles. Made them in to two seperate symbols. Imported .mp3 audio into 3rd layer for lipsyncing. Extended the head and mouth around 60 frames, and key framed aprox. 20 key frames on the mouth layer. Head is fixed position. I try play back and starts at 24 fps, at around 15 frames later I drop to 16 fps for 5 frames and goes back to 24. The more frames I add the more frame drops I get. Gets to the point where i can't no longer sync with audio. Even audio begins to lag.


      I don't get it. I used my friends macbook pro and it runs smoothly. The entire project ran smoothly, with like 400 frames and 10 layers, with out lag or single framedrop.


      I tried the lipsync only document into the other 2 windows computers both latest flash cc, same lag problem. I'm frustrated I can't do any work unless I use my friends mac book pro. He's is also running latest flash cc. I would assume my  primary computer would be able to run  any heavy load, but i can't even work on it while a simple laptop has no problem playback 400 frames of the same project. I tried the best I can to movements with audio with framedrops, but when I run it on my friends computer I'm behind 5 frames about 10 seconds in real time.


      Please, I need this for work. This is important to me. Mean while I have to use his laptop, until my pc is able to run it with out frame drops.

        • 1. Re: Flash frame drops on windows but not mac
          Colin Holgate MVP & Adobe Community Professional

          Make sure you're using an ActionScript 3.0 FLA, not HTML5 Canvas. Set the audio layer sync to Stream instead of Event. You should now be able to play the animation and it will keep up. It may still be dropping frames, but it shouldn't get far behind in sync.

           

          Also, check View/Preview Mode, you may have the Windows version set to Full, and the Mac set to one of the other settings.

          • 2. Re: Flash frame drops on windows but not mac
            Mcifuentes Level 1

            You are A-MA-ZING!!!! I changed the view / preview option from "anti alias" to "fast" which made sense why it would start to slow down like crazy when i added roations. What irritated me was that I knew my problem would be solved by something so simple, I just couldn't find it anywhere on the Internet.  I checked in preferences, multiple times, I never once checked the view options. Thank you so much!