16 Replies Latest reply on Mar 14, 2007 8:03 AM by vinceg5

    CHM crashes on execution

    tjvis22
      I'm running RoboHelp HTML X5.0.2 Build 801. After updating a couple of smaller projects and generating new CHMs, these help files crash a few seconds after I launch them. When I launch the file using "View Primary Layout", I get a message stating that hhlauncher.exe has encountered a problem and needs to close. When I launch the help file outside of Robohelp as an independent application, (just double-clicking the file), I get a message from Windows Data Execution Prevention, and the file exits. If I place the file in the associated application directory and launch it from the application itself, I get a message stating that hh.exe has encountered a problem and needs to close.

      These projects are under version control (SourceSafe), if that makes a difference.

      All that was updated were some images and the style sheet on each project.

      Other projects that I have updated recently do not have this problem.

      One last thing I noticed is that these projects are also merged into one larger project. Whenever I open the larger project and view the smaller ones that are having the problems, they work fine.

      I can always go back and use the earlier versions (which don't have any problems) but I'd really like to figure out why this is happening. Thanks for any help you can give me!
        • 1. Re: CHM crashes on execution
          Captiv8r Adobe Community Professional & MVP
          Hi tjvis22

          From what you are describing, it sounds like the compilation failed to complete and the .CHM file is corrupt. You might want to ensure you are seeing the Output View inside RoboHelp HTML (View > Output View) and see if the compilation is gagging somewhere along the way.

          Cheers... Rick
          • 2. Re: CHM crashes on execution
            tjvis22 Level 1
            As far as Robohelp is concerned, the compilations complete flawlessly. Output view never encounters anything out of the ordinary. The crash always seems to occur after clicking on a topic link, whether it be in the table of contents, index, or after a search.
            • 3. Re: CHM crashes on execution
              WA3CAS Level 1
              Are you using Windows Media Center? Some (not all) of my *.CHM files crash in Media Center but do not crash in WindowsXP.

              . . . JBrush
              • 4. Re: CHM crashes on execution
                tjvis22 Level 1
                I'm using XP. Strangely enough, the problem doesn't seem to happen in Windows 2000 or earlier. I've tried just about everything I can think of. I think I might just try to rebuild the projects and hope for the best.
                • 5. Re: CHM crashes on execution
                  RoboColum(n) Level 5
                  Is the problem just on these smaller/updated projects. Also do you have access to the CHMs before you applied the updates? Do these open OK? If so, can you tell us if you added anything out of the ordinary?
                  • 6. Re: CHM crashes on execution
                    tjvis22 Level 1
                    Thanks for the renewed interest!
                    Ok, here's what I've tried so far--

                    The problem only occurs on certain projects.

                    The projects in which I'm having the problem were all "inherited" by me from someone who no longer works here. I have rolled back the projects in sourcesafe to their previous versions and--surprise! they still have the problem. This at least tells me that, whatever the problem is, it is not a result of the updates I made.

                    As I said in the previous post, it seems to be an operating system-specific problem, as I cannot reproduce the problem in Windows 2000.

                    I disabled Windows Data Execution Prevention, and all that accomplished is the Data Execution Prevention message does not come up before the crash.

                    I tried deleting the hh.dat file that saves favorites, etc., to no effect.

                    I have tried executing the chms while in safe mode and in diagnostics mode to see if there was some kind of conflict--no help there.

                    I restored the hh.exe and hhctrl.ocx files from the Windows System Configuration Utility.

                    I have tried compiling the projects using Microsoft's HTML WorkShop--The help file still crashes, only not as quickly....

                    I am using Internet Explorer 7--I have not yet tried reverting back to IE6.

                    The closest thing to a common symptom that I have is that it always crashes hh.exe while going from one topic to another--and that it seems to take too long to load a topic. For example, if I click on a topic in the TOC (or index, or search results) it might take a couple of seconds for the topic to display, or it may crash.

                    I am still going to try reverting back to IE6 before I rebuild all of these projects from scratch. If nothing new happens I'll take the smallest one and import all of the topic htms to a new project and see how it goes from there.

                    Any other suggestions are most appreciated!
                    • 7. Re: CHM crashes on execution
                      RoboColum(n) Level 5
                      Do any other - non inherited - projects work OK in IE7? Can't help feeling there is something in your legacy code that IE7 hates. If it works in IE6 at least we'll know.
                      • 8. Re: CHM crashes on execution
                        Brian.Mccaffery Level 1
                        I may be clutching at straws, but did you completely de-install IE6 before installing IE7?

                        Just something lurking in the back of my mind.

                        Brian
                        • 9. Re: CHM crashes on execution
                          tjvis22 Level 1
                          Back on IE6 and-- they work! Spread the word.
                          Thanks for all your help!
                          • 10. Re: CHM crashes on execution
                            RoboColum(n) Level 5
                            OK but IE7 does and should support CHM files. I still have IE6 so can't test but others have. There has got to be something in your legacy code that doesn't fit well. This may not be your priority just now but if you get a chance it would be good to know for the future what it was.
                            • 11. Re: CHM crashes on execution
                              tjvis22 Level 1
                              Yeah looks like my next course of action is compatibility testing.

                              Now that I can at least launch the files I can look at them a little more closely. Right off the bat I notice that the projects in question all have browse sequences, while the ones that have always worked do not.

                              I'll post here if I find anything definitive.
                              • 12. Re: CHM crashes on execution
                                RoboColum(n) Level 5
                                Do they also have glossaries? If they do, I bet they don't work in IE7 either. It may be down to the version of the HHACTIVEX.DLL file you have installed. Maybe there's a newer version required for IE7 users. Just a hunch!
                                • 13. Re: CHM crashes on execution
                                  tjvis22 Level 1
                                  Got rid of the browse sequences--meaning I deleted everything from the Browse Sequence Editor AND removed the Browse Sequence check mark from the Window Properties.

                                  Reinstalled IE7. The old ones that still have the browse sequences do crash. The newly compiled help files without the browse sequences no longer crash.

                                  Colum--none of my projects that had the problem have glossaries. Actually, the only project I have that contains a glossary has never crashed.

                                  I think I'm done with this. Remove your browse sequences if you have IE7.

                                  Thanks for everybody's input!

                                  TV
                                  • 14. Re: CHM crashes on execution
                                    RoboColum(n) Level 5
                                    I'm glad you got your problem sorted TV but the issue IS NOT with running browse sequences in IE7. I've just run a test in IE7 and everything runs fine with them. There must be something about your specific browse sequences that caused the problem. Just want to set the record straight and avoid lots of users having coronary problems
                                    • 15. Re: CHM crashes on execution
                                      Amebr-ke0mH4 Level 2
                                      Yep, it's not specifically the browse sequences. I have one file that crashes one person's PC every time, but is fine for everyone else I've tried, including people with IE7 installed.

                                      I'm about to get the techs to investigate the software/hardware DEP settings to see if that is the difference between the IE7 people.

                                      I'll post again if I find out anything useful.

                                      P.S. I particularly like the advice from MS "To avoid this behavior, contact your program vendor to see if an update is available that enables the program to work correctly with DEP." Methinks they will be less than helpful.
                                      • 16. Re: CHM crashes on execution
                                        vinceg5
                                        I realize this topic has gone cold, but I'd just like to add that getting rid of browse sequences seems to have worked for me as well. I had all of the same problems as tjvis22, and tried all of the same remedies. The only thing that seems to have worked is getting rid of browse sequences. Strangely, as others have noted, some CHMs with browse sequences don't have any problem. Still, it does appear to be the Browse Sequence option in the Window Properties dialog that triggers -- if not causes -- the problem in certain CHMs. Having a browse sequence defined doesn't seem to trigger the problem, but checking the Browse Sequence option in the Windows Properties dialog does.