12 Replies Latest reply on Mar 28, 2008 12:38 AM by ThinkInk

    Corrupt Connection Key Error

    davolson
      I'm administrator for a small set of Contribute clients (about 20). A new client, who has just installed Contribute 4.0, keeps getting an error message when he tries to double click the connection key I'm emailing him: "The connection key you're trying to import is corrupt. Please contact your administrator for assistance."

      I'm using Contribute 3.0 at this point. I have successfully sent a key to another new client also using 4.0, so that doesn't seem to be the problem. Does this error pop up due to firewall or other problems at my client's end? I've sent him multiple connection keys so I doubt the key is actually corrupt. Help!
        • 1. Re: Corrupt Connection Key Error
          HangD Level 1
          Is the client using a web mail account which you have mailed? (yahoo, gmail, hotmail) if so check out the following technote
          Connection key from web e-mail client fails to connect
          http://www.adobe.com/go/tn_18734

          Is the client using mapped drives?
          Connection keys set to mapped drives fail to connect
          http://www.adobe.com/go/tn_16690

          General Troubleshooting Contribute connection problems
          http://www.adobe.com/go/tn_16592

          Other questions: Are they using a connection key that includes SFTP connection information? Are they being managed by CPS?

          Do you know if the client is behind a Cisco PIX firewall?
          http://www.adobe.com/go/fc1a435a
          • 2. Re: Corrupt Connection Key Error
            davolson Level 1
            Thanks. The client is not using a web mail account, they're using MS Outlook and a regular POP mail account. They are not using mapped drives. I don't know what SFTP connection information is; I"m sending just a regular old connection key using the Administer Websites... menu item like I do for our other users. I don't know what CPS is. They are not behind a cisco PIX firewall.

            They are using the 30-day trial version of Contribute 4.0. Should the connection key be able to work if that's the case?

            We were going to use tech support tonight but find out they're only available Mon-Fri and only up until 7 PM (central time). This is quite maddening.

            Dave Olson
            • 3. Corrupt Connection Key Error
              Christyb
              I am also having a problem with the corrupt connection key. It is none of the problems mentioned in the response by HangD.

              It is two users only, I have connected other customers with keys within the last two weeks. The users with the problem had just had their computer re-imaged.

              All our users are in-house (inside the firewall). And I did not use special characters in the password.

              Please help!!
              • 4. Re: Corrupt Connection Key Error
                Christyb Level 1
                Update:

                It seems all users have lost connectivity, but I can publish at will. My permissions are not blank as described in the hub issue in the Knowledge Base, nor are we using different versions of Contribute.

                Any Advice?
                • 5. Re: Corrupt Connection Key Error
                  ThinkInk Level 2
                  Maybe you can trie to make a manual connection at the PC of one of your users, to see which settings are needed to create a working connection.
                  • 6. Re: Corrupt Connection Key Error
                    Christyb Level 1
                    Thanks for the input. The current situation is this. The only "key" that is not corrupt is the Admin key. When I send that key my customers are able to connect. Obviously, I do not want these customers to have admin rights.


                    • 7. Re: Corrupt Connection Key Error
                      ThinkInk Level 2
                      Don't know the answer, but I have some considerations:
                      Are you and your users using multiple versions of Contribute?
                      Have you tried saving the connection key to your harddisk first and then send teh keys to your users?
                      • 8. Re: Corrupt Connection Key Error
                        Christyb Level 1
                        Thanks for all your input!

                        We use one version of Contribute, and I have saved the keys to my harddrive before sending them. I send an Admin key to my backup person, and she can create keys.

                        It must be something on my system. We once used Contribute 3, and Adobe Support says I should reinstall Contribute 3, break my connection, and then send all my users new keys. They would not tell me what files left over from Contribute 3 were causing the problem (I just wanted to delete them from the web server).

                        Adobe's advice does not make sense to me, as I was able to send keys until about two weeks ago.
                        • 9. Re: Corrupt Connection Key Error
                          ThinkInk Level 2
                          If I understand you right, you and your users are using Contribute 3 (macromedia version) and you yourself once installed Contribute CS3 (adobe) and administered the website with this trial version? Is this what happened?

                          Installing CS3 and administering a website with this version, gives the major problem that you cannot administer the website properly with the older version after you uninstall CS3.

                          I think you will have to re-install Contribute 3 to get rid of this problem, like adobe suggested.

                          I think you should and can savely remove the _mm (admin) folder from the server, and everything should be fine by reconnecting everyone using the conn-keys. Be sure to make a backup of this folder first. I don't know if you have to remove _baks and _notes folders to, but I would try first without doing this, because it can be much work.

                          I would suggest you let your 'backup person' make backup admin keys for yourself too, so you can easely reconnect after re-installing.

                          I hope this will work and you get it solved.
                          • 10. Re: Corrupt Connection Key Error
                            Christyb Level 1
                            Wow, thanks again for all the help. I read your comments on other questions all the time.

                            I guess I will have to break down and do what Adobe support suggested.

                            Just so you completely understand the situtation:

                            We had Contribute 3
                            I tested a trial version of Contribute CS3
                            Then I uninstalled the trial version
                            and then we purchased and upgraded myself and all Content Owners to Contribute CS3
                            • 11. Re: Corrupt Connection Key Error
                              ThinkInk Level 2
                              No we do not understand eachother right. I thought you did not upgrade to CS3... and went back to using version 3 (macromedia) after using the trial. When you and your users are all on CS3, the things I said don't make sense.

                              But now I understand you are in this situation:
                              1. you and your users are using CS3
                              2. you cannot send your users new connection keys because they are corrupt...

                              And now:
                              I had problems also using the trial version of CS3. I thought these troubles would be gone by purchasing the upgrade to CS3, but they were not, and I even returned the upgrade to the store.

                              The problems where only gone after a complete new installation of Web Premium (including Contribute CS3) on a new computer.

                              So what I would suggest is try to uninstall your program as complete as possible (registry keys, server _mm folders, local folders, also) and then reinstalling the program. I presume you were the only one who had the trial installed before purchasing the CS3 version?
                              • 12. Re: Corrupt Connection Key Error
                                ThinkInk Level 2
                                Copy from another post, it may come in usefull (registry):

                                Clear the Contribute Preference and also login to the server where the site id created and delete the .LCK files causing this issue.
                                To clear the preference follow the below mentioned steps.
                                1) Quit Contribute
                                2) Go to C:\Documents and Settings\<username>\Local Settings\Application Data\Adobe\ and delete Contribute CS3 folder.
                                3) launch command prompt and run "reg delete "HKCU\Software\Adobe\Contribute 4.1" /f" if you are using Adobe Contribute CS3.

                                For Macromedia Contribute 3.0 run reg delete "HKCU\Software\Macromedia\Contribute 3.0" /f and delete the folder in your local machine in C:\Documents and Settings\<username>\Local Settings\Application Data\Macromedia\