1 Reply Latest reply on Nov 5, 2015 6:27 AM by Bob Somrak

    how to install lightroom 2.7 will not open on os el capitan

    davidh39542852

      I am trying to install lightroom 2.7 on os 10.11 but the package will not open. I get an error saying this is from an unsupported maker.