0 Replies Latest reply on Nov 16, 2006 10:27 PM by wally_errrr

    LoadMovie etc

    wally_errrr Level 1
      Hi there,

      I am currently assigned to a project that is an old application written for Flash Player 6.0 and in AS 1.

      I have got this application up and running to an acceptable level and then became a requirement for menus inside the application. So I built the menus as separate files in Flash 8.0 that I load into the old application using LoadMovie, so in effect I have Flash 6.0 AS1 and Flash 8.0 AS2 content running inside Flash Player 9.0....hope this makes sense.

      Anyway my concern is this, when the user is inside the application and navigates back to the start using one of the buttons in the newer menus, I am unloading all movies loaded using LoadMovie I am unloading them using unloadMovie. The playhead of the old AS1 movie then goes to and plays a couple of frames before it calls LoadMovie again.

      The trouble that some movies do not seem to be reloaded or should I say unloaded....its very confusing I know!!

      All these Movies are being loaded into "dummyClips" which are just an instance of a blank movie clip in my library......is this a bad thing to do?

      So what happens if the playhead moves off the frames where these dummyclips exist and they have movies Loaded into them?

      Hopefully you can tell what I am doing, which in the most part is working, there just seems to be the odd random case where somethign will screw up, which of course are the worst bugs of all....no pattern....yet.

      Thanks for your time,

      Nathan