2 Replies Latest reply on Nov 16, 2006 11:55 PM by DCG2

    SWF in Firefox

    DCG2
      Hi all,

      I'm a student at The Art Institute of Portland. For an Intro to CBT class, I decided to use Captivate for my first project. (With no regrets -- I love the program and plan to purchase it.)

      Here's a truncated version of the project:

      http://www.greatchurchwebsites.org/GIMP/GIMP_tutorial_test.htm

      (truncated to save forum members download time).

      There's a lot to be done on the project to improve it, which I'll be working on, but here's the problem about which I am writing:

      In Firefox on the Mac and PC, the exit button at bottom right on the Flash skin does not work. Moreover, the Control/Command Tab does not work (when the movie is playing) to create a new tab. (Not that there is any reason or need to do so, but it's something I noticed.)

      Everything appears to work OK in Internet Explorer.

      The full version of the tutorial was exported to Flash 6, I think. The test was exported to Flash 8, just to see if that was the source of the problem. (It's not.)

      When I opened the exported htm file in Dreamweaver, I got a message about needing to convert something (the OBJECT tags or something) and said yes to it, so the htm code is not the same as that which was exported from Captivate. (I mention this in case that's the source of the problem.)

      Tonight I'll try the tutorial with a different skin. Perhaps that's the source of the problem.

      Anyway, anyone have any ideas why the Exit button doesn't work in Firefox? The fact the some of the GUI is disabled in this manner (including the Control/Command Tab not working), will be disconcerting to users, I'm afraid. (When I first tested the full project online using Firefox on the Mac, there seemed to be other keyboard shortcuts that stopped working.)

      Thanks in advance.

      Sincerely,

      David Gillaspey
        • 1. Re: SWF in Firefox
          Paul_D Level 1
          David,
          The exit button works here in firefox, if you have javascript turned of in firefox then it will not work.
          Also I would try to stick with the original code rather than letting dreamweaver convert as viewing your site with IE gives me a script error

          • 2. Re: SWF in Firefox
            DCG2 Level 1
            Hi Paul,

            Thanks for the response.

            First, allow me to clarify. By "Exit" I mean the button with the X in it at bottom right on the playback controls of the swf file, assuming the controls are positioned along the bottom of the Flash movie.

            Normally, I would not have JavaScript turned off; but I did check to ensure it was turned on in Firefox. However, I would hope that none of the buttons in the playback control would rely upon JavaScript. (One apparently does, as you'll see.) I did turn off JavaScript in Firefox (as a test) and found that all the buttons in the playback control worked fine with JavaScript turned off (except, of course, the Exit button).

            I tried a different skin, to ensure that the source of the problem wasn't a bug in the particular skin I first used. That was not the case.

            I found that the Exit button won't work even when I preview the tutorial on the PC using the "Preview In Web Browser" option, which opens the exported movie in Firefox.

            You are correct in stating that the html exported by Captivate doesn't need to be changed. (There's more to the story than that, but I won't bore you.)

            Firefox has a JavaScript Console, which I have not heretofore used. The Console yields a clue as to the reason the Exit button won't work. This is the error message repeatedly displayed in the Console after I have repeatedly clicked on the Exit button: "Scripts may not close windows that were not opened by script."

            Thus, the Exit button apparently is intended to trigger JavaScript code to close the window, only the window was never opened by JavaScript in the first place, so JavaScript can't close it. Apparently, the Exit button assumes the swf file gets played in a popup window, opened via a link or button that the user has clicked. That will often be the case, but not always. In my case, the swf is embedded in a plain old HTML page.

            The code that Captivate exported looks like this:

            <title>GIMP tutorial</title>
            <script src="standard.js" type="text/javascript"></script>
            </head>

            <body bgcolor="#F1F4F5">
            <center>
            <script type="text/javascript">
            <!--
            writeDocument('<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase=" http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="780" height="589" ID="Captivate1">'+
            '<param name="movie" value="GIMP_tutorial_test_skin.swf">'+
            '<param name="quality" value="high">'+
            '<param name="loop" value="0">'+
            '<embed src="GIMP_tutorial_test_skin.swf" width="780" height="589" loop="0" quality="high" pluginspage=" http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" menu="false"></embed>'+
            '</object>');
            //-->
            </script>
            <noscript>
            <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase=" http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="780" height="589" ID="Captivate1">
            <param name="movie" value="GIMP_tutorial_test_skin.swf">
            <param name="quality" value="high">
            <param name="loop" value="0">
            <embed src="GIMP_tutorial_test_skin.swf" width="780" height="589" loop="0" quality="high" pluginspage=" http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" menu="false"></embed>
            </object>
            </noscript>
            </center>

            Anyone know how to resolve this problem short of always displaying the swf file in a popup window?

            Thanks in advance.

            Sincerely,

            David Gillaspey