The code is correct....
But, what i want to know is, are using the Identifier name of
the moviclips ???
"emptyMovieClip" should be an Ideintifier name for an empty
clip in the library.
and "boxesRow" should refer an identifier name of another
movie clip in the library...(its should also contain some object
for the visibility check)...