1 Reply Latest reply on Nov 13, 2015 8:19 AM by Szalam

    nVidia display driver crash when using Adobe After Effects 3D ray-traced renderer

    BalazsG

      I am Balázs Gáspár a Technical Video Editor, and I am facing a really serious crashing issue with the graphics driver when trying to render video frames with Adobe After Effects 3D ray-traced renderer. I have written both to nVidia and here to the forum, as this is a really important case for me and I do not know who can help after all my research. You will find the mostly nVidia related paragraphs in green, and the mostly Adobe After Effects related paragraphs in blue.

      I am using the most up-to-date driver of nVidia (354.42-quadro-grid-desktop-notebook-win8-win7-64bit-international-whql). In October I used the “353.06-quadro-grid-desktop-notebook-win8-win7-64bit-international” driver, but it also crashed, that was the reason then I have updated to 354.42.

       

      My system configuration:

       

      OS

      Windows 7 Enterprise x64

      Chassis

      HP Z230 Workstation

      Processor

      Intel Xeon E3-1280 (3.6Ghz), 4 core, Hyper-threading disabled in BIOS

      Memory

      32 GB

      Graphics processor

      nVidia Quadro K2000

      Storage

      256 GB SSD

      Displays

      2x, DELL U2414H, extended desktop

       

      The 3D ray-traced scene is relatively simple, it consists of only 2 point, 1 ambient light sources and 50-100 objects (10-30 layers) at the same time, all of which are angular, so I guess there are not so much polygons to deal with. The renderer quality is set to 5 which is low compared to the 10-12 that I usually read on After effects forums. This means short and not so dense ray trancing and few motion blur samples per frame. The project is 16-bit depth, but I tried to use to 8 or 32 bit depth.

      I also tried to switch to CPU rendering in Settings / Preview / GPU information but it was rather slow. Tried ticking and unticking the untested GPU for CUDA acceleration option, it did not help neither.

      I also tried to render into various formats such as Intel IYUV, V210 10-bit YUV, Uncompressed UYVY 422 8bit, Quicktime DVCPro HD and H.264.

       

      Since I do not want to decrease the workload of my graphics card (the demands are not so high I think), I have tried the suggestion of the nvidia.com/suppport site, that I may change the “Microsoft Windows imposed time limit (TDR)” in the registry.

      http://nvidia.custhelp.com/app/answers/detail/a_id/3007/kw/error%203/session/L3RpbWUvMTQ0N zI1MDcyMS9zaWQva0tuOWNlQm0%3D

       

      I increased it in 2 steps, by default it was 8 seconds, then adjusted to 16 sec, now it is 32 sec. (TdrDelay in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\GraphicsDrivers)

       

      I have also read through the following topics:

       

      In nVidia Control panel, I tried to use the default settings, then set “Power Management Mode” to “Prefer maximum performance” as the forums below suggested then tried the “3D App – Video Editing” preset and then on the top menu “Desktop / Enable Video Editing mode”. None of these 4 options ceased the crashes.

       

      I attached the Directx Diagnostics output (dxdiag system app) and two GPU logs made with GPU-Z, the crashes can be clearly seen on data and the charts, when the graphics card suddenly stops and restarts. I also attached some crash dump, live kernel report, and application crash dump files as it was suggested in this page: http://nvidia.custhelp.com/app/answers/detail/a_id/3335/kw/error%203 . The last attachment (AE Layers and keyframes.png) is the overview of a composition that I have not been able to render because of the always reoccurring crashes.


      I'm using Adobe Send & Track for my attachments. Please download them, because the online preview of the Excel files is not in the right format:
      "GPU_Log1.xlsx" at: https://files.acrobat.com/a/preview/994bfe31-565d-4411-b2b9-b416c82e7b01
      "GPU_Log2.xlsx" at: https://files.acrobat.com/a/preview/073d8924-594e-4dee-aa02-a1f0e8f0e2ad
      "DxDiag.txt" at: https://files.acrobat.com/a/preview/d483e1c3-64bd-499f-8a13-08e4dd7fdb7a
      "MiniDump.7z" at: https://files.acrobat.com/a/preview/4092bd4c-33f7-4724-a649-b95ca181d349
      "Live kernel reports.7z" at: https://files.acrobat.com/a/preview/e5c8c4e9-00d7-47e6-9e2c-adc72bac44a5
      "CrashDumps.7z" at: https://files.acrobat.com/a/preview/ed64b854-a09a-4583-aeae-b6414603e5e5
      "AE Layers and keyframse.png" at: https://files.acrobat.com/a/preview/ca49e490-b47d-493a-b636-92fd40dddf57

       

      Some forums suggested not to use AE Ray-traced renderer, but I think this could not be an answer. It is a well built, easy to use module in AE, that – in some cases – is more effective to use instead of Cinema4D. The reason of my project was especially to practice and test AE’s built in renderer with a dummy 3D scene.

       

      Thank you for reading my message and I hope we can find a solution in this case, have a nice day!