6 Replies Latest reply on Jun 9, 2009 1:45 PM by Lionlanka

    Unable to load movie playlist?

    Level 1
      I'm really starting to regret Upgrading to Director 11. I didn't have any of these issues going from MX to MX 2004. All I'm trying to do is make a simple projector work on a Mac and it's one issue after another. Not to mention all this after updating a whole boat load of Xtras 11 requires.
      The new one is this;

      Unable to load movie playlist. Does the INI file exsist? It must contain a section '(Movies)' with an entry 'Movies01=pathname.dir'.

      I've already read a couple of other forum post with the same error message going on with others but can't find certain files required to make the fix like the 'Projec32.skl',
      and I don't know how to read, let alone make an .INI file.

      I'll mention I got this error after updating to Shockwave 11 EVEN though I was not publishing a Shockwave movie.
      I know I just need to include a certain file on my CD when I burn one because all works great on the desk top, but I'm throwing darts trying to figure out what the CD burn is missing.

      So to make a long story short does anyone know what I might be missing?
      I'm new to making director movies for the Mac, and even using a Mac so I might need it spelled out a little more for being a novice.

      Thanks in advance. :o)>

      PS I tried making a Mac Projector from my PC with no good results either.

        • 1. Re: Unable to load movie playlist?
          mikem75
          that's likely going to be a path length issue. At least that's the message you get on a pc. I believe the longest path you can have to your movie is 256 characters (including the name of the movie). Try moving your director file closer to the root of the drive and republishing the movie.

          Mike M
          • 2. Re: Unable to load movie playlist?
            Level 1

            Hello Mike,

            When I burn everything to CD all the director movies are on the root, along with the xtras, so i don't think I'm even getting close to using 256 characters.

            I did skip a version of Director going from Director 9 to Director 11. But why would these issues only go wrong after burning to a CD?

            • 3. Re: Unable to load movie playlist?
              Level 1

              I take that back, it doesn't work on the desk top of the Mac either.  :o(

              • 4. Re: Unable to load movie playlist?
                mikem75 Level 1

                This is a very frustrating problem.  I have run into it as well, but can't tell you exactly how I solved it, its been a while since I've seen it.  It does have something to do with the length of the path to your projector when its published.  I would suggest moving your movie as close as possible to the root of the drive, you may even want to restart to ensure all the internal variables have been reset and then republish the movie.

                 

                If you publish the movie from your authoring location and then copy the projector to a cd or the desktop the path length seems to be built into the projector at publishing. So that does not solve the problem.  It is fairly easy to get a long path name - c:/mylocaldrive/documents and settings/yourusername/yourprojectsfolder/yourprojectname.dir has a path name length of 100 characters!  I realize you are on a mac, but the same rules apply.

                 

                I also might be mistaken with the maximum path length.  Perhaps its 128 characters?

                 

                Has anyone else run into this error?

                 

                Mike M

                • 5. Re: Unable to load movie playlist?
                  fazstp Level 2

                  I tested this on my Mac with a path length of over 400 chars and it still opened so I don't think path length is an issue. I know it used to be.

                   

                  What type of projector are you publishing? Standard/ Shockwave? Are you using a projector ini? Are you creating a bundle?

                  • 6. Re: Unable to load movie playlist?
                    Lionlanka

                    Tha a lot Mike, That works for me. There was a length issue in my case.