12 Replies Latest reply on Nov 30, 2015 11:18 PM by drhemani

    Win32 API error 193. Could not call C function: private_load_AgCoreTest

    davis65553906 Level 1

      Hi guys,

       

      When I try to run Lightroom, I get the following error messages:

       

      • Win 32 API Error 193 ("(unknown error)") when calling ::Load library from getCFunction
      • Could not call C function: private_load_AgCoreTest

       

      Then I can't have access to my library or to make a new library by importing files.

      I'm running it on a notebook with Windows 10 64-bit, Nvidia GeForce 850m GTX and an Intel Core i7 processor, with 12 Gb of RAM and a 500 Gb SSD (Samsung 840 EVO). Everything with the latests drivers.

       

      I've already tried to unninstall and reinstall the program, all my Visual C++ packages and dll's. I've also already checked my permissions to the catalog folder and granted full access. I've also tried to run Lightroom as administrator.

       

      None of these fixed the problem.

       

      What should I do?