4 Replies Latest reply on Nov 24, 2015 10:25 AM by Mrinmay Majhi

    Trying to update from LR5 to LR6.3

    jaydenc12418897

      Hiya, I have Lightroom CC and currently have Lightroom 5 installed on my Mac. I am trying to update to Lightroom 6.3 but Lightroom keeps telling me that my software is up to date. But I don't have the latest, so a little confused about that. I am running on a Mac Book Pro 13", Version 10.10.5. 2.4GHz Core i5. 4GB DDR3 Memory, Graphics HD 3000 384MB. My Mac Book is 3.5 years old. I am wondering if my Mac is too old. Your help would be appreciated. Cheers