1 Reply Latest reply on Nov 24, 2015 12:45 PM by EWC-abahmer

    Apache won't start after install of ColdFusion11

    EWC-abahmer

      I'm performing an upgrade from CF8 to CF11, but need to keep CF8 on the server until CF11 is running properly on my production server.

      Apache 2.2.26, Tomcat 7.0.64

      Windows Server 2008_R2 (virtual)

       

      I have the original CF 11.0.0 file direct from Adobe. I chose a standard install (not JEE) with Apache web server and all sub-components, no servlets. The install proceeds without issue.

       

      In Apache httpd.conf, I see the section of code that had been added by my earlier install of CF8:

      LoadModule jrun_module "C:/ColdFusion8/runtime/lib/wsconfig/1/mod_jrun22.so"
      <IfModule mod_jrun22.c>
          ...more code...
      </IfModule>

       

      I also see the line of code that the installer added for CF11:

      Include "C:\Apache2\conf\mod_jk.conf"

      I can also find the mod_jk.conf file in the place it references and all of the CF11 files and folders that it references exist.

       

      I commented out the section above for CF8 and attempt to restart Apache, but it fails to start. There are no entries in Apache logs to explain what happened. If I remove the comments for CF8 and comment out that line for CF11, then Apache starts fine.

       

      Since the install, I have three issues:

      1. Apache won't start properly with the CF11 mod_jk.conf
      2. I notice that the ODBC services are not running in Windows for CF11 (they are for CF8)
      3. I can't navigate to the CF11 Admin. CF8 admin works fine (likely on the same port, eh?)

       

      Ideas about why Apache won't start properly? Thanks.

        • 1. Re: Apache won't start after install of ColdFusion11
          EWC-abahmer Level 1

          I finally found a useful entry in the Windows system event log:

          The Apache service named  reported the following error:
          >>> httpd.exe: Syntax error on line 526 of C:/Apache2/conf/httpd.conf: Syntax error on line 2 of C:/Apache2/conf/mod_jk.conf: Cannot load C:/ColdFusion11/config/wsconfig/1/mod_jk.so into server: The Apache service named is not a valid Win32 application.

           

          In looking at my previous installation notes for CF8, I found a similar problem.

           

          Solution:

          Extracted 64-bit Apache mod_jk22.so from C:\ColdFusion11\runtime\lib\wsconfig.jar (zip) to C:\ColdFusion11\config\wsconfig\1 as mod_jk.so (to essentially replace the mod_jk.so that the CF11 installer put in place)

           

          Now, commenting out the CF8 section of my Apache httpd.conf and allowing the CF11 line allowed Apache to start properly. The mod_jk.conf file applies an alias to the CF11 CFIDE so that my web address can reach the CF11 Admin!

           

          Completing the configuration/setup process in CF11 then allowed me to download and install Update 7. Upon self-restart, the ODBC connectors are also running!

           

          Situation with my issues:

          1. Solved
          2. Solved
          3. Solved