5 Replies Latest reply on Nov 24, 2015 2:43 PM by joeskander

    need to upgrade from LR V3 to LR V5 to run it on MacOs10.7.5

    joeskander

      need to upgrade from LR V3 to LR V5 to run it on MacOs10.7.5?