1 Reply Latest reply on Feb 14, 2009 12:48 AM by Peter Grainge

    CSH WebHelp Not Working with Safari 3.2

    Tom.H Level 1
      Hi All,

      I'm working on a WebHelp project for a web-based application. The application is specified to run on MSIE, FireFox, and Safari. I've been creating the WebHelp output and testing it on all three. The only problem I found on Safari originally is that the TOC seems to get stuck when expanding a book to show child topics. I see the message "Loading, click here to cancel..." but clicking on it does nothing. Sometimes it finishes loading on its own and the message disappears, otherwise it just hangs on the message but all of the child topics are visible, so there must be nothing left to load. This one isn't a big deal.

      But today, a developer pointed out the the context-sensitive help isn't really working at all. I'm not sure if this was always broke (can't say for sure that I tested the context-sensitive links within Safari or not, but I thought I did). Here's what he said:

      "... the Help window does not open properly in Safari. The window is positioned in the very lower right corner. In addition, it does not directly open to the appropriate page but instead displays the error ‘The filename, directory name, or volume label syntax is incorrect’. When reviewing the JavaScript file, TRoboHelp.js, it appears that there may be some missing logic for the Safari browser. Do you have, or are you aware of any way for us to get an update to the TRoboHelp.js file to see if this solves our issue?"

      Anybody have any thoughts?
        • 1. Re: CSH WebHelp Not Working with Safari 3.2
          Peter Grainge Adobe Community Professional (Moderator)
          I have seen the Loading issue but I think it was in an older version of RH than I just used to test. In RH7 the TOC from a single project opened correctly. Merged WebHelp is different and I know that issue still exists. I haven't tried it with RH8. What version are you using?

          I also tested CSH using the URL startpage.htm#path/targettopic.htm method and that worked OK.