4 Replies Latest reply on Nov 21, 2006 5:39 PM by ravigehlot

    Verity Collection Unabled to Create Anything

    ravigehlot
      Why am I getting this error?

      ----------------------------------------------
      Unable to create collection sts.
      Unable to create collection sts.
      An error occurred while creating the collection: com.verity.api.administration.ConfigurationException: Fail to create the index. (-6220)
        • 1. Re: Verity Collection Unabled to Create Anything
          Spidre
          Without seeing code, it is hard to diagnose. Best guess is that you have the path attribute either wrong, or missing.
          The path attribute defines where you want the verity indexes stored (not the path to the files you are indexing) In SHOULD NOT include the name of the collection

          Make sure that your path attrib is defined and that it is an accessible folder.

          So, to create your collection do this:
          <cfcollection action="CREATE" collection="documents" language="Englishx" categories="yes" path="e:\jrun4\verity\collections\">

          It will create this folder to store the index info in:

          e:\jrun4\verity\collections\documents
          • 2. Re: Verity Collection Unabled to Create Anything
            ravigehlot Level 1
            It is not a problem of directories because I have the right one. However, I forgot to mention that I am running a Linux box.
            • 3. Re: Verity Collection Unabled to Create Anything
              sduncanute Level 1
              I am having a similar problem but only with the UNI language pack. It is indexing fine with the English or Englishx packs. It also worked fine until we updated to the latest patches (7.0 worked, 7.02 does not)

              I'd posted the following in the 'getting started' section but maybe it should be here instead.

              I have two verify collections. The English collection is working ok. The French collection using the 'uni' multilanguage does not index using the Cold Fusion code, and if I try to index it on the server directly, I wait and wait and eventually it will give me a page not found.

              When I was at 7.0, this index worked fine. Now after upgrading to 7.02, I cannot create the index.

              I have tried deleting the collection and starting over but I get the same problem.

              This is the code that had been working:
              <CFLOCK NAME="CFINDEXSEILOCK" TYPE="exclusive" TIMEOUT="90">
              <CFINDEX ACTION="refresh" COLLECTION="sei" KEY="E:\UTEWebsite\Francais\" TYPE="path" URLPATH=" http://www.ute-sei.org/Francais/" EXTENSIONS=".htm, .html, .cfm, .pdf, .doc" RECURSE="yes" language="uni">
              </CFLOCK>

              Any thoughts?
              • 4. Re: Verity Collection Unabled to Create Anything
                ravigehlot Level 1
                OK. ANSWER FOUND! For anyone that uses LINUX pay attention to permissions. Very often errors like "Failed to create index" with Verity and "500 Internal Server Error" with Apache has to do with Linux permissions. Sometimes a .cfm file will NOT be found on the server if the permission of it's directory is not set correctly. I found the solutation for many of my problems with Linux when I set the permissions of CFM directories to be 775 and cfm files to be 664. In my case, if anyone runs through the same problem go to your verity directory and set the collections permission to 775 and BOOMmmmmmm it WORKS!!!