12 Replies Latest reply on Nov 30, 2015 3:09 AM by khatwani

    Lightroom 4 catalag cannot be opened because it is too new to be used by this version of Lightroom

    Sam WVPF

      I have recently done a clean install of my OSX (Yosemite) which has required me to reinstall my Lightroom program. Having done this and updated it to the very latest release of my version as before (4.4.1) it no longer allows me to open any of my old catalogs. Every time i try to open one of my old catalogs it says 'The Lightroom catalag cannot be opened because it is too new to be used by this version of Lightroom. Would you like to select a different catalog?'


      I cant figure out why, other than is there some connected application that i havent installed that it thinks it needs?


      Pretty desperate for help here as i cannot work on any of my clients catalogs any more!


      Kindest regards, Samuel