3 Replies Latest reply on Nov 30, 2015 12:55 PM by InterMurph

    Lightroom CC 2015.3 Hangs on Import

    InterMurph Level 1

      Since I upgraded to the 2015.3 release, I can no longer import photos.  I have tried importing from an SD card and from a hard disk, but both show the same failure.

       

      I am running Windows 7.

       

      First, when I start the import process, the grid view does not display any previews for new photos.  If I double-click on a photo, it will show me the full-screen preview.  It does show previews for older photos that I have already imported.  But in the grid view, the new photos are all blank.

       

      Next, I select Copy, and enable Rename Files as I always do.  When I click the Import button, I get the import screen, which says "Importing files..."  The status bar in the upper left says "Copy and import photos", and the progress bar starts at about 2/3 complete.  It stays there, but no matter how long I wait.  On occasion, I get a handful of photos imported, but most of the time, no photos are imported. 

       

      When I give up and click the X to cancel, a popup says, "No photos or videos were found to import."

       

      I also backed up my catalog, thinking that the optimization step might help.  But it did not help.

       

      I also tried importing into a new catalog, but that also did not help.