1 Reply Latest reply on Nov 20, 2006 11:00 AM by Fordian-Slip

    CFFile Write problems

      Hi Folks -

      I was wondering if anybody has come across this problem where CFFile just doesn't want to work. I am not receiving any errors within either the CF logs or the system logs. CF is set up as a local system account and has full control permissions .

      Everytime I try it, the page is processed and displays the info I want to save, but the CFFile code does not execute.

      I know the web page is working because I have a NOW() on the page to let me know that everything is working and is executing everytime.

      Here's the line of code:

      <cffile action="WRITE" destination="E:\Inetpub\development\intranetapps\doug\test" file="news.txt" output="news_output1">

      I have tried: output="news_output1" or output="#news_output1#"
      destination="E:\Inetpub\development\intranetapps\doug\test" or destination="E:\Inetpub\development\intranetapps\doug\test\"

      And nothing seems to work.

      I have worked with CFFILE in the past but never to the extent of these problems.

      Any and all info is appreciated.


        • 1. Re: CFFile Write problems
          Fordian-Slip Level 1
          Hi Folks -

          I solved this on my own... sometimes it's good to RTFM....

          Here's the solution:

          <cffile action="WRITE" file="E:\Inetpub\development\intranetapps\doug\test\news.txt" output="#news_output1#">

          The attribute DESTINATION is not needed... The FILE attribute must be fully qualifies. And the OUTPUT attribute must have ## for a variable reference.