2 Replies Latest reply on Aug 3, 2016 6:26 AM by mave1969

    After Effects error: Input Contract Violation

    Pyrosousa Level 1

      Receiving an error when opening any after effects projects on certain computers. I know the project is working, since it worked on the same computer last night, and I have tried backups/other projects.

      EDIT: This is only happening on my college's computers in the labs. My personal laptop has no problems/errors.


      It's completely random which computers get the error, but once you get it no projects will open on that machine.


      I have gotten the "file something.mp4" is damaged or unsupported message for other file types (mov, wav, mp3, mxf) I converted the mp4 in question to an uncompressed MOV, and also tried importing other video files i know are working. But still get the error.


      Restarted the computer, restarted AE, trashed prefs, the whole nine yards and nothing has changed. Sometimes the error goes away if you open the project 4-5 times. Other than that I haven't found any sort of real solution.


      Screen Shot 2015-12-06 at 1.50.55 PM.pngScreen Shot 2015-12-06 at 1.50.59 PM.png

      Screen Shot 2015-12-06 at 1.51.04 PM.png

        • 1. Re: After Effects error: Input Contract Violation
          Pyrosousa Level 1

          For anyone who might run into this error. We figured out on our school computers the caches were getting written to a shared folder. (So that they can be cleared out by student employees if space on the computer needs to be freed up.)

           

          So if UserA used a quicktime file it would create the caches, and then UserB, logs in and tries to access/use/delete those cache files, and wouldn't have permission, giving this error for some reason.

           

          Solution: Give all users complete access to the After Effects Cache folder. Super simple solution. But super hard to diagnose, and troubleshoot.

          1 person found this helpful
          • 2. Re: After Effects error: Input Contract Violation
            mave1969 Level 1

            I was having this problem and although your solution didn't work for me, it did prompt me to look at other things related to the cache, since I had been using more than one user account on the same machine.

            Preferences > Media & Disk Cache > Clean Database & Cache did the trick for me, and got me out of a hole when I was tight up against a deadline, so thanks for the inspiration!