2 Replies Latest reply on Jun 18, 2017 3:34 PM by MulkMedia

    Hi! I'm having problems copying a composition on AE.

    guilhermet

      Hi! I'm having problems copying a composition on AE.

       

      When I click CMD+C the program crashes and this message appears

      (After effects has encoutered an error [../../../../../ext/adobe/MediaCore/MediaFoundation/API/ Inc/Keyframe/Keyframe.h-146]).

      I'm using AE CC 2015 on OS X Yosemite. Hopefully someone will be able to help me. Thanks

        • 1. Re: Hi! I'm having problems copying a composition on AE.
          Dave LaRonde Level 6

          Don't use AE CC 2015.  Get AE CC 2014 and use it.  It works as advertised.... mostly.

          • 2. Re: Hi! I'm having problems copying a composition on AE.
            MulkMedia Level 1

            After Effects CC 2017 PSD layer copy crash

             

            TL;DR

            One position keyframe’s outgoing velocity was set very close to zero. AE didn’t like it.

            -

             

            I'm having the same or very similar issue in After Effects CC 2017.2 (and .1) in Windows 10 64-bit.

            This is the only post I've found that looks like the same issue, so I'm tacking this on.


            The crash for me occurs when copying certain PSD layers or comp layers containing PSDs.

             

            When copying one or more layers:

            The error dialog first says 'after effects debug event',  'after effects has encountered an error.' and points to a non-existent folder on  a local SSD called "d:\ae1421cc\releases\2017.03\shared\adobe\mediacore\mediafoundation\api\inc\..." then I can't see the rest of the text or scroll it.


            Error log notes:

            error 487 
application specific info: ...\support files\file.dll


            Found Mylenium’s answer to a different dll file coming up in the log with the same error number: Tried updating GPU driver (for GTX980ti): Crash still occurs.


            Tried on another PC. Win 7, AE CC 2017.1 - same crash when copying PSD layers.

            Tried on a mac: “[../../../../../../shared/adobe/MediaCore/MediaFoundation/API/Inc/Keyframe/Keyframe.h-14 6”  (yay now I can read the other end of the message)

             

            Searching for “Keyframe.h-146” errors: Looks like it’s possibly related to keyframes (duh) or the project is corrupt somehow.

             

            A fresh copy of the same PSD in the same comp (with no animation) DOES copy without crashing.

             

            Deleting the keyframes from the original PSD layer (it’s one of about 120, so I need a fix not a work around): Yes I can now copy it!

             

            So, the problem is in THE KEYFRAMES.

             

            Tried resetting them all to linear: Can copy the layer. OK. Now I suspect there is ONE keyframe causing this. I’ve wasted a few hours already, so why not find the cause.

             

            There are seven position keyframes on the PSD layer. No other animation. one is linear, so I’m pretty sure it’s not that one.

             

            Process of elimination:

            Deleting the first three keyframes: Yes, can copy the layer.

            Deleting only the most ‘extreme’ keyframe out of those three suspects: crash when copying the layer. Re-opening project.

            Deleting only the first one of three: Yes, can copy the layer. Woo. Found it.

            Details for the keyframe:

            type: position.

            Incoming Vel. Speed 0, Infl 33.33333%

            Outgoing Vel. Speed 0.00024, Infl 100%

             

            That outgoing speed looks pretty suspicious in computer terms. With C4D Octane stuff I’ve seen crashes quite often when float values are at the extremes, which is why I tried this value first.   

             

            Guess what: Changing the outgoing speed of that one position keyframe from an ALMOST ZERO value to ZERO allowed me to copy the layer with keyframes intact.

             

            Weirdly I could copy the keyframes without the layer, no sweat. I actually tried that at the start of my journey, which led me to believe the KFs weren’t the problem.

             

            I feel stupid it took me so long to figure this out, but I think it’s worth posting for other ‘challenged’ types like myself.

             

            Now to copy paste the new keyframe to sixty or so layers!