3 Replies Latest reply on Jun 24, 2016 5:22 PM by johnr34574229

    Premiere Elements 14 error message -- "Project file not compatible with the current version of Premiere Elements"

    cdavidhall

      Hi, I just installed Premiere Elements 14 and licensed it.  I worked on my first project and everything went smoothly.  I was able to create an mpeg4 video.  Then I tried to  burn a disk.  Not only did the disk burn not work, when I tried to reopen the project it says "the file is not compatible with the current version of Premiere Elements".  It's the only version I've ever had.  The incremental saved files that Elements makes during a project all do not work either.  The program is installed on a newer iMAC.  I also have Creative Cloud installed, including Premiere Pro and its associated programs like After Effects.  I have not used Premiere Pro on this computer.  My MAC OS is Yosemite 10.10.4.  I would appreciate any suggestions.

       

      Thank you.

      David Hall