3 Replies Latest reply on Dec 16, 2015 3:58 PM by JimHess

    Installed previous purchased version of lr5- can't load newer catalog

    samdavec

      I cancelled and uninstalled creative cloud and installed a version of LR5 which I had purchased earlier, but it cannot open my lightroom catalog with error message ".. this older version of lightroom cannot open this more recent version catalog". But I know there must be something wrong with this as I had reverted to lr5 even before cancelling CC and it was able to open this catalog.