5 Replies Latest reply on Dec 28, 2009 10:51 PM by jessonerik

    Adobe Air Linux won't install on Eee PC

    Alan_Chambers_(UK)
      Hi - I've been getting some advice on this from @smmehadi on Twitter but it's hard 140 chars at a time...

      I'm trying to install Air on my Eee PC 701, which runs Xandros Linux. I know this isn't a supported distro but I know some others have got it to work.

      When I run the installer, running as root, I get the licence panel and then click "I Agree". I then see the "Adobe AIR Setup" panel and the progress indicator goes abot 3/4 of the way along before it stops and displays the message: "Sorry, an error has occurred" "An error occurred while installing Adobe AIR. Installation maynot be allowed by your administrator. Please contact your administrator"

      As advised, I've done a chmod +x on the installer. I've tried to capture the .airinstaller.log file but it doesn't exist. If I created it, nothing is added to it by the installation.

      I do have a bunch of files in /tmp/airCrashLogs - are they of interest to you? I've also noticed some messages appearing in ~/.xsession-errors.

      Many thanks,

      Alan
        • 1. Re: Adobe Air Linux won't install on Eee PC
          syed mehadi
          Hi Alan,
          First of all as your AIR installer is crashing, so please check if you have sufficient free memory available (more then around 200 MB to be on safer side).
          The please repeat these steps on terminal:
          1. touch ~/.airinstall.log
          2. chmod +x Desktop/AdobeAIRInstaller.bin
          3. Desktop/AdobeAIRInstaller.bin
          this will popup the GUI for installation, proceed to the point it goes
          when installer has failed or crashed open the log file in any editor
          4. vim ~/.airinstall.log
          or
          gedit ~/.airinstall.log or kate ~/.airinstall.log
          and copy the contents of log (~/.airinstall.log) and send them to syed-attherateof-adobe-dotcom

          -Syed
          • 2. Re: Adobe Air Linux won't install on Eee PC
            Alan_Chambers_(UK) Level 1
            OK - I've done all those things but still the same - and there's nothing in .airinstall.log,which only exists at all because I created it earlier today. The only difference is that I've got the AdobeAIRInstaller.bin in /home/user rather that on the desktop - I assume that can't matter.

            Before running the installer, I had just over 200MB memory free. It's a 500MB machine and nothing else is running apart from system processes. At the point of the failure, free memory is down to 111MB.

            Thanks!

            Alan
            • 3. Re: Adobe Air Linux won't install on Eee PC
              syed mehadi Level 2
              Try out the silent installation using:
              /home/user/AdobeAIRInstaller.bin -silent
              and see if that works or writes some contents in .airinstall.log
              and check that free memory is sufficient enough (~200 MB), before installing

              -syed
              • 4. Re: Adobe Air Linux won't install on Eee PC
                Alan_Chambers_(UK) Level 1
                Hi Syed,

                I've got it working now! Strangely, even with the silent install it was failing and not writing to the log. However, I wanted to copy/paste the messages it gave in the terminal window for you to see but the standard terminal window doesn't seem to allow copy; so I launched Konsole, which does support copying, and re-ran the silent install there. To my surprise it worked!

                I now have Twhirl running nicely on my Eee PC.

                Thanks for your support,

                Alan
                • 5. Re: Adobe Air Linux won't install on Eee PC
                  jessonerik

                  I’ve done a bit more research since writing this post, and it seems that some people have managed to get AIR installed on their 701s after all.  My guess is that as I originally thought, the installer is failing due to insufficient free memory, so somehow I have to work out a way to free up some RAM, long enough to complete the installation. Anyway, thanks for your comment – it gives me some hope! By

                  dedicated servers