0 Replies Latest reply on Feb 4, 2009 10:10 AM by jesse911

    FCKEditor not working after upgrade to SDK 3.2

    jesse911
      I have code that instantiates the FCKeditor in javascript. I upgraded the version of the SDK from 3.1 to 3.2, and now I get the error:

      ReferenceError: Can't find variable: FCKeditor

      The following code is how this editor is being instantiated:

      [Bindable]
      private var moderatorTextFckEditor:String = '<head>' +
      '<script type="text/javascript" src="../fckEditor/fckeditor.js"></script>' +
      '<style type="text/css">' +
      'body { margin: 10px ; }' +
      '</style>' +
      '</head>' +
      '<body>' +
      '<script type="text/javascript">' +
      'var sBasePath = "../fckEditor/";' +

      'var oFCKeditor = new FCKeditor( "ModeratorTextFCKEditor" ) ;' +
      'oFCKeditor.BasePath = sBasePath ;' +
      'oFCKeditor.Height = 400 ;' +
      'oFCKeditor.Create() ;' +

      '</script>' +
      '</body>' +
      '</html>';

      The problem, I have deduced, is the new FCKeditor line above is not working because it can find the definition, which is in the fckeditor.js file. One of my suspicions is that the deployment directory structure has change, therefore the line above that states <script type="text/javascript" src="../fckEditor/fckeditor.js"></script>, needs the src changed. I have tried several paths, and nothing has worked. I am also assuming this could be some changes in the latest verision's handling of Javascript. I do not know.

      I repeat, this working just fine in 3.1 and only the upgrade to 3.2 was done. So, does anyone know what has changed in SDK 3.2 or AIR 1.5 that would affect this? Or am I doing something that is basically wrong?