8 Replies Latest reply on Apr 23, 2017 9:54 AM by dan-gra

    Error trying to import Aperture Library: "?:0: Attempt to index nil value"

    dan-gra

      Hi all, I have tried several times move to Lightroom from Aperture, but keep running into the same error message each time. I am running the latest versions of all apps and OS on a MacBook pro.

       

      The process that leads to the error is:

      1. Select the Aperture to Lightroom Plug in.
      2. it runs its integrity check. I have 52482 images and require 177GB of space. I have 304GB available.
      3. I select import without changing any settings
      4. It starts with a progress dialogue at 0%
      5. Within seconds a dialogue appears with "An internal error has occurred. ?:0: attempt ti index a nil value"

       

      Oddly, before I ran into this error, I had imported a very small test Aperture Library with 150 or so images. This worked perfectly. I contacted Adobe chat and they suggested renaming the Presets folder per the instructions here: LR Error "attempt to index a nil value"

      I tried this, and even eliminated my test Lightroom data since it was not important. So I was really starting the app fresh with no presets or library.

      Tried to import again - same failure. Grrrr. Want to get started...

       

      I also tested the following:

      1. Repair permissions on Aperture library. Same failure
      2. Repair Aperture Library. Same Failure

      The only Aperture Library fix I have not tried, simply because it will take a lot of time, is rebuild the Library. However, I am not sure that this is an Aperture data issue, or the Adobe Plug-in.

       

      Since Support is closed due to the holidays, I hope someone might be able to offer some other troubleshooting approaches?

       

      Thanks!