13 Replies Latest reply on Sep 11, 2017 12:54 PM by AbuTim

    ePub book won't open

    lauries17438022 Level 1

      I downloaded an ePub book from my library. It downloaded in .acsm format and demanded that I download Digital Editions to read it, which I did.  It won't open the book, however.  Error message: "Error! Check Activation."

        • 1. Re: ePub book won't open
          Nanaky Level 5

          Macintosh:

           

          1. Open Adobe Digital Wditions.
          2. Press Command+Shift+D to deauthorize Adobe Digital Editions.
          3. Select Erase Authorization.
          4. Click OK and quit Adobe Digital Editions.
          5. Navigate to /Users//Library/Application Support/Adobe/Digital Editions and drag the activation.dat file to the trash.
            If you are using 10.7, see Access hidden library files | Mac OS 10.7 and later.
          6. Open Adobe Digital Editions and reauthorize.

           

          Windows:

          1. Close all applications.
          2. Choose Start > Run.
          3. In the Open text box, type regedit and then press Enter. The Registry Editor opens.
          4. In the left pane of the Registry Editor, locate the following registry key: HKEY_CURRENT_USER\Software\Adobe\Adept
          5. Select the Adept key.
          6. Choose File > Export.
          7. In the Export Registry File dialog box, select Selected Branch under Export Range. Enter a name and location for the backup registry key, and then click Save.
          8. Right-click the Adept key and choose Delete.
          9. In the Confirm Key Delete dialog, click OK.
          10. Close the Registry Editor.
          11. Open Adobe Digital Editions and reauthorize.
          • 2. Re: ePub book won't open
            briank99751229 Level 1

            Now it won't allow me to re-authorize!!!re-auth error.JPG

            On a prior loop around this problem I used v3.0 to get authorization, which succeeded but then I got this error message.

            error message.JPG

            So far this has been just one endless loop of error messages but I cannot get it to function properly.  Note that everything was working fine for ~18 months with the most recent download being about 2 weeks ago.  But, I have always received ePub files and suddenly this week, Overdrive which is the interface for our library, started serving up an ACSM file which will not work with v3.0.  I updated to v4.5.2 and started getting these error messages everyone else is noting.

            • 3. Re: ePub book won't open
              Nanaky Level 5

              You Error show a connection problem wiht server. Has you check if your secutry Programms anything blocked?

              • 4. Re: ePub book won't open
                briank99751229 Level 1

                Yes.  I have turned OFF Norton Antivirus and Windows firewall.  No effect.  Now what?

                Why did they switch to ASCM from ePub?  I suspect better copyright management but THAT is the one change I see which seems to why/when the problem started.

                • 5. Re: ePub book won't open
                  lindat99044596 Level 1

                  I too am unable to download ebooks from my library via overdrive using ADE and my Adobe ID.  This has occurred to two other members of my family at the same time on three different computers.

                   

                  From the number of posts appearing, this problem must be caused by a change not on each users computer, but in the infrastructure for Adobe or Overdrive.  This problem is extremely frustrating and makes me hate Digital Restrictions Management (DRM) because it seems to hurt those that honestly purchase or borrow ebooks.

                   

                  Prior to this ebook download/authorization problem occurring, I had downloaded many books over the years using ADE 1.7.2 and Overdrive from my local library.

                   

                  Since encountering this problem I have installed and tried several versions of ADE and each has an error message when I try to download an EPUB book via a *.acsm file using ADE.  Following are the error messages for each version:

                   

                  ADE 1.7.2

                   

                    {Book Name}:

                    IO Error on Network Request.

                    Please check you network connection and try again.

                   

                    Network path:

                    https://acs.cdn.overdrive.com/ACSStore1/0111-1/577/81E/24/{57781E24-E884-4437-32DB-8E38DA532F37}Fmt410.epub

                   

                    Event Detail:

                    Error #2038

                    --- end ---

                   

                  ADE 2.0.1, 3.0.1, 4.0

                   

                    Connection Error Detected

                   

                    Digital Editions could not connect to the fulfillment server.  Please

                    make sure you are connected to the Internet.

                   

                  ADE 4.5.2

                   

                    Connections Error

                   

                    Digital Editions could not connect to the activation server. Please

                    make sure you are connected to the Internet.

                   

                   

                  Something changed outside of all our computers, and I hope that someone with technical expertise can diagnose the problem and identify the change causing all of us grief.

                  2 people found this helpful
                  • 6. Re: ePub book won't open
                    Nanaky Level 5

                    Off not help allways. Better your add the software as sure probramm.

                    briank99751229 schrieb:

                     

                    Yes. I have turned OFF Norton Antivirus and Windows firewall. No effect. Now what?

                    Why did they switch to ASCM from ePub? I suspect better copyright management but THAT is the one change I see which seems to why/when the problem started.

                    • 7. Re: ePub book won't open
                      briank99751229 Level 1

                      I have turned OFF Norton and Windows firewall, disabled pop up blocker.  No effect.  That said, it had worked for last 2 years without exposing my computer to malicious software as these steps do.  Kind of crappy product that requires you to make yourself so vulnerable just to download a book!!

                       

                      Still, doing all that (and reg editing and deleting Adept key) still did not fix the problem.

                      • 8. Re: ePub book won't open
                        briank99751229 Level 1

                        Success!!!!!

                         

                        None of the prior steps helped me at all.  However, what I just did that worked was to delete ALL versions of ADE on my computer and reinstall version 4.0.

                         

                        I had updated from v3.0 to v4.5.2 to deal with the ASCM files type but got in the same endless loop of failure to authorize or failure to connect to authentication server, both errors (falsely) suggesting I was not connect to the internet.

                         

                        The registry editing, DE-authorizing/re-authorizing, shutting down windows firewall/Norton antivirus etc. just cycled me through these error messages without solving the problem.

                         

                        I don't even know when v4.0 was downloaded or if it was automatic at some point, but by uninstalling v3.0 and v4.5 and selectively installing v4.0 everything worked the way it should.

                         

                        I must say I found the chat people with whom you connect when you click the Help tab in ADE was worthless (actually worse than worthless since the snarkily pointed out it was free if necessary software and therefor not supported) and the Forum articles simply cycled me through useless and sometimes scary (deactivating all my PC's security features) steps without resolving the problem.

                         

                        V4.0 works as it should.   Now I just have to figure out how to assure it will not auto-update and put me back in server failure hell.

                         

                        Hope this helps others.  Good Luck out there...

                        1 person found this helpful
                        • 9. Re: ePub book won't open
                          Nanaky Level 5

                          Fine. Thanks for the info how can solved the problem.

                          • 10. Re: ePub book won't open
                            mattsplatt007 Level 1

                            I can back up what briank said; had very similar experience.

                            I resolved this same issue by uninstalling all versions of ADE, reinstalling v3.0, editing the registry to remove the Adept key and then re-authorizing the machine.

                            Note that I did try installing the latest version of ADE v4.5 but it created another error where removed books kept popping up. Apparently this is something to do with a cloud synchronization bug in that version.

                            1 person found this helpful
                            • 11. Re: ePub book won't open
                              lindat99044596 Level 1

                              Thank you briank99751229 for posting how you resolved the issue.  :-)

                               

                              I experienced success similar to mattsplatt007.

                               

                              To get ADE working with Library downloads, I had to deauthorize and completely uninstall all versions of Adobe Digital Editions, and ensure that the registry was clean (delete HKEY_CURRENT_USER\Software\Adobe\Adept registry keys).  After that with a clean install and authorization of ADE 3.0.1, I was able once again to download books from my Library into ADE and then transfer these to my Kobo Glo eReader.

                              • 12. Re: ePub book won't open
                                lindat99044596 Level 1

                                I believe I might have discovered the reason why people with existing ADE 1.7.2 installations have suddenly become unable to download EPUB eBooks from the library.

                                 

                                The reason is a recent change in the .acsm file in the <operatorURL> stanza from http:// to https:// secure socket layer communication.

                                 

                                This change must have been implemented on the servers which provide the library eBook lending service and create the .acsm files.  My guess is that ADE 1.7.2 does not support https:// communication.

                                 

                                This change in communication protocol would explain why many people using ADE 1.7.2 have suddenly experienced problems downloading library EPUB eBooks.

                                 

                                 

                                With the recognition of this change in mind, I deauthorized ADE 1.7.2 and completely uninstalled it including deleting the registry key

                                "HKEY_CURRENT_USER\Software\Adobe\Adept".

                                 

                                After this I was able to install ADE 3.0.1, authorize it, and then proceed to successfully download a book from the libary using these new .acsm files that contain https:// in the <operatorURL>.

                                 

                                Now that I have a workaround for this change, I am able to again read library EPUB eBooks on my KOBO eReader.

                                 

                                I think it would be extremely helpful to Libraries and users if Overdrive were to announce this change.  Either that or restore the

                                old use of http:// instead of the new https:// in the <operatorURL>.

                                • 13. Re: ePub book won't open
                                  AbuTim Level 1

                                  OK: This problem has been going on since Dec. 2015, and the issue is, as the discussion header says, "Not Answered". The suggestions from the Community point to a variety of slash-and-burn directions (e.g., you must deauthorize your whole ADE setup and remove a Library file). Is it because ADE is a "free" (but essential for using certain document files) app that nobody at Adobe has stepped in and tried to find the kinks in the code that may have led to this impasse?