1 Reply Latest reply on Jan 3, 2016 6:05 PM by edwinlimlx

    Edge Animate JavaScript library fails to load

    bryanb40692452

      At Say Media we produce quite a number of HTML ads using Edge Animate.  We have noticed within the past few weeks that some of the ads we have been running using Edge Animate 5.0.1 seem to intermittently fail to load.  In examining this problem further, we see that a JavaScript error is being thrown when loading the Edge JavaScript library.

       

      Here is the URL that we were using:

       

      http://animate.adobe.com/runtime/5.0.1/edge.5.0.1.min.js

       

      We noticed that, rather than getting JavaScript, we were getting an HTML error message as a response when the browser requested this library:

      <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml"><head><META HTTP-EQUIV="CONTENT-TYPE" CONTENT="TEXT/HTML; CHARSET=utf-8"/><title>Error</title></head><body><H2>Error</H2><table summary="Error" border="0" bgcolor="#FEEE7A" cellpadding="0" cellspacing="0" width="400"><tr><td><table summary="Error" border="0" cellpadding="3" cellspacing="1"><tr valign="top" bgcolor="#FBFFDF" align="left"><td><STRONG>Error</STRONG></td></tr><tr valign="top" bgcolor="#FFFFFF"><td>This page can't be displayed. Contact support for additional information.<br/>The incident ID is: N/A.</td></tr></table></td></tr></table></body></html>


       

      However, we don't always get this error.  It seems to be intermittent.

       

      If I had to guess, I would think there was an intermittent error getting returned by the origin server when the CDN is refreshing its cache.  Sometimes the CDN servers cache the normal JavaScript and sometimes they cache this HTML error message.

       

      Has anyone else seen this issue?  Is there any way to contact someone at Adobe to see if there is a problem with their servers?

       

      Thanks,

       

      Bryan