4 Replies Latest reply on May 17, 2006 5:58 PM by mablack

    WSDL did not load successfully

    mablack
      I'm getting the following error (from the 'fault' event) when I try to invoke a WebService through an app running on a Mac machine (OS X 10.4.6, both in Safari and Camino):

      quote:

      Cannot invoke method MethodName as WSDL did not load successfully

      The app is built with Flex Beta 3, and works fine in Firefox/IE on Windows. The web server itself is running on my Mac, and I can open the URL to the WSDL in my browser, so there doesn't seem to be any access/permission problems...
      Is there any Mac users here that have WebServices working, or anyone that has any ideas on what's going wrong?

      Cheers,

      Michael
        • 1. Re: WSDL did not load successfully
          kmurray24 Level 1
          Could still be authority. I am able to get the WSDL on a web service using my user, but if I use the same user to execute the call it fails. I have to use a more robust user to execute the call.. hey, you do what ya gotta do to get by... Good Luck
          • 2. Re: WSDL did not load successfully
            mablack Level 1
            it's weird that the app works fine on other computers running on the same network though - it works on Windows and not Mac OS X
            • 3. Re: WSDL did not load successfully
              Level 7
              Michael,

              Here is a response I got from the Flex Data Services Team:

              I'd be looking out for a security sandbox issue in my flashlog.txt file
              (assuming that I had registered a fault handler for my WebService!) where by
              the Mac webserver is now remote and the SWF is being loaded from another
              computer, perhaps the Windows box where it originally worked locally. That
              is, the remote Mac webserver is out of the security domain of the SWF and
              you need to allow the Windows box hosting the SWF to contact the remote
              domain.


              Let us know if this helps.

              --
              Jason Szeto
              Adobe Flex SDK Developer


              "mablack" <webforumsuser@macromedia.com> wrote in message
              news:e3tvbn$7md$1@forums.macromedia.com...
              > I'm getting the following error (from the 'fault' event) when I try to
              > invoke a
              > WebService through an app running on a Mac machine (OS X 10.4.6, both in
              > Safari
              > and Camino):
              >
              > Cannot invoke method MethodName as WSDL did not load successfully
              > The app is built with Flex Beta 3, and works fine in Firefox/IE on
              > Windows.
              > The web server itself is running on my Mac, and I can open the URL to the
              > WSDL
              > in my browser, so there doesn't seem to be any access/permission
              > problems...
              > Is there any Mac users here that have WebServices working, or anyone that
              > has
              > any ideas on what's going wrong?
              >
              > Cheers,
              >
              > Michael
              >


              • 4. Re: WSDL did not load successfully
                mablack Level 1
                Hi Jason,

                I didn't have the crossdomain.xml file on my webserver - oops :) It works fine now.
                Thanks for your help.

                Michael