5 Replies Latest reply on Jul 24, 2016 4:43 PM by kdlindy

    DRM protection/authorization issues for library ebooks

    veronicah65505512

      I download books through BC libraries and transfer them onto a Kobo through Adobe Digital Editions. None of the titles will open and I keep getting the message about the DRM protection asking me to authorize the device. The problem is I'm not sure why I am getting the message when my computer and device ARE already authorized. An agent for Adobe redirected me here, can anybody help? I also tried to open a sample title on the device as per his request and my screen just went blank when I tried

        • 1. Re: DRM protection/authorization issues for library ebooks
          jennifers8576749

          I am having the same issue. I can view and read my book using my Samsung tablet but it won't work on my Kobo.

          • 2. Re: DRM protection/authorization issues for library ebooks
            lorik57907231

            I am having the same problem.  I understand that ADE allows for 6 devices to be authorized under one Adobe ID.  I can't get the second one to be recongnized.  If I download books from the library onto the second KOBO, it will not open them and I get an error message.

            • 3. Re: DRM protection/authorization issues for library ebooks
              Leon Capart

              Well, for the last 2 weeks I tried just about everything, including trashing files, and finally resetting my Nook to factory specs. Nothing helps. I get an error message: "Loan token not found" when I try to read a book from the local library thru OverDrive.

              I can read the ebooks on my Mac screen, even the ones on the Nook. But I cannot open them on the Nook, instead I get this error about token.

              It worked for at least 2 years without a hitch. So I went onto OverDrive help, Adobe help, Nook help,Library help, and everything I was told to do I did.

              One thing though, when I try to de-autorize my Mac, the authorization shows a 45 digit password?? It does not work, neither does the Adobe password I used to get on this board. So this last resort of "Erase authorization" cannot be achieved.

              How can I erase the authorization? I could probably go into the system and trash a file or 2, but I cannot do this safely.

              • 4. Re: DRM protection/authorization issues for library ebooks
                dkenn1224

                I am having the same problem. I download a book from BC Library to my laptop. Adobe Digital Editions works fine there. I then transfer the book to my KOBO reader. Some books work fine as they have for over 5 years. With some books however I get the message on my KOBO: "oops! this document couldn't be opened .....DRM licence has expired.....renew the document licence and try again".  The book opens on my laptop and I have 21 days left on the licence but it simply won't open on the KOBO.

                I have on occasion kept trying and the book opens on my KOBO after about 4 days of loading and reloading it. Of course I then have less time to read the book before it does expire.  This time it has been 6 days of trying and no luck getting it to open at all.

                I tried an online chat with Adobe about this but was on hold for 30 minutes then connected to someone who took 30 minutes to tell me to try this site for answers.  Their customer service is non existent it seems.

                I see that you have not gotten an answer to your 5 month old question either.

                I hope someone out there has an answer for this issue as I really miss reading on my KOBO.

                • 5. Re: DRM protection/authorization issues for library ebooks
                  kdlindy

                  was this question every answered?