10 Replies Latest reply on Jan 4, 2016 5:48 PM by johnrellis

    XMP file is not read my lightroom CC

    magnusb81

      My catalogue fails quite frequently so i have enabled that XMP file is generated for all changes I do. However, when I reimport a file then the changes I did are not there.

       

      Here one can see the filename:

      Dropbox - Screenshot 2016-01-03 14.06.28.png

       

      and here is the file reimported to LR:

      https://www.dropbox.com/s/g3mlsxs69gn890x/Screenshot%202016-01-03%2014.06.55.png?dl=0

       

      I tried to "resync" the folder and also right click on the file "meta data" and "Read metadata from file". But nothing is working.

       

      Any idea?

        • 1. Re: XMP file is not read my lightroom CC
          Just Shoot Me Adobe Community Professional

          If your catalog fails, get corrupted or whatever, frequently then you have problems with the hardware in your computer. No file ever gets corrupted, fails, for no reason. The reasons are hardware failure of some type. Could be your hard drive or the RAM in your system.

           

          If you have a subscription for LR then you also have Photoshop. Try opening an images through ACR and Photoshop and see if the edits you have done are displayed.

          • 2. Re: XMP file is not read my lightroom CC
            magnusb81 Level 1

            It is actually my permissions for my user. When i created a new user it was no problem. Also this is only related to CC as it always worked with LR4 and LR5.

             

            Finally, any idea how to call the XMP file within LR?

            • 3. Re: XMP file is not read my lightroom CC
              johnrellis Most Valuable Participant

              There could be several things going on.  The most efficient way to troubleshoot is to upload a sample .nef and corresponding .xmp to Dropbox (or similar), and then we can take a look at the actual files.

               

              (But building on Shotistbond007's response, a higher priority should be to get your catalog reliable.  In normal operation, LR's catalogs are very robust.)

              • 4. Re: XMP file is not read my lightroom CC
                Just Shoot Me Adobe Community Professional

                magnusb81 wrote:

                 

                It is actually my permissions for my user. When i created a new user it was no problem. Also this is only related to CC as it always worked with LR4 and LR5.

                 

                Finally, any idea how to call the XMP file within LR?

                You could try using the Synchronize feature. There is an option to update Metadata, have that option checked. But I suspect the XMP files are also getting corrupted in some way or they were never written to in the first place. Or since you had to Re-import your images to a fresh catalog file the XMP files the original catalog created got overwritten when you did the re-importing.

                • 5. Re: XMP file is not read my lightroom CC
                  magnusb81 Level 1

                  Here you can see the NEF and XMP file:

                  https://www.dropbox.com/sh/39ow7rw8j2u1j0b/AABpW7aaOcEJbBRPtA0PzDlza?dl=0

                   

                  Would be great if you could have a look!

                   

                  cheers!

                  • 6. Re: XMP file is not read my lightroom CC
                    Just Shoot Me Adobe Community Professional

                    I would but it really makes no difference. I do believe that on Re-Import of the images to a new Catalog file, because of catalog problem, the original XMP file that held your edits got overwrote by a new XMP. As far as LR knows these images had never been import and No XMP file for them was ever created.

                     

                    Jusdt for the heck of it I downloaded them and opened the NEF in ACR. No edits of any kind had been applied. Which is what I expected as the XMP file got overwritten when you re-imported them into a new catalog.

                     

                    Try it yourself. Take a couple of the images and do some heavy editing, colors, contrast, whatever, so much so there is no mistaking you have edited it.

                    Then open a New catalog and Re-import them into that new catalog. Do your original edits show up? Or has the XMP file been overwritten by the re-import.

                    • 7. Re: XMP file is not read my lightroom CC
                      johnrellis Most Valuable Participant

                      Normally, when you import a raw file, if there is a corresponding .xmp sidecar, LR will read the metadata from that sidecar, picking up any edits or changes to metadata stored in the sidecar.  It will not overwrite the sidecar on import.

                       

                      It appears that the .xmp sidecar you uploaded was written by Photomechanic, setting the rating to 1.  As Shootistbond007 observed, it doesn't contain any LR develop settings:

                       

                      <x:xmpmeta xmlns:x="adobe:ns:meta/" x:xmptk="XMP Core 5.1.2">
                      <rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
                        <rdf:Description rdf:about=""
                          xmlns:photoshop="http://ns.adobe.com/photoshop/1.0/"
                          xmlns:xmp="http://ns.adobe.com/xap/1.0/"
                          xmlns:photomechanic="http://ns.camerabits.com/photomechanic/1.0/"
                          xmlns:aux="http://ns.adobe.com/exif/1.0/aux/"
                        photoshop:DateCreated="2015-12-27T01:52:37+01:00"
                        xmp:Label=""
                        xmp:Rating="1"
                        photomechanic:ColorClass="0"
                        photomechanic:Tagged="False"
                        photomechanic:Prefs="0:0:1:003851"
                        photomechanic:PMVersion="PM5"
                        aux:ImageNumber="3851"/>
                      </rdf:RDF>
                      </x:xmpmeta>
                      

                       

                      So perhaps you invoked Photomechanic after LR wrote its version of the .xmp?

                       

                      • 9. Re: XMP file is not read my lightroom CC
                        magnusb81 Level 1

                        Hmmm, I now opened the other XMP files and I cant see anything from lightoom. I have this setting enabled:

                        https://www.dropbox.com/s/fnwjm42nijv9nr0/Screenshot%202016-01-04%2020.58.07.png?dl=0

                        am I missing something?

                        • 10. Re: XMP file is not read my lightroom CC
                          johnrellis Most Valuable Participant

                          That setting, Automatically Write Changes Into XMP, is the correct setting.   Since you've been having catalog problems, it's hard to know what might be going on.  A couple of possibilities:

                           

                          - You used Photo Mechanic to rate the photos, and it overwrite the LR .xmp sidecars.  (I'm not very familiar with Photo Mechanic, but I'd be mildly surprised if it did that.)

                           

                          - The Automatically Write Changes Into XMP setting is per-catalog, and perhaps it wasn't enabled in the catalog in which you originally made all your edits.

                           

                          Do you have backups?  At this point, I think you need to resolve the permissions issue so that the catalog is robust.