3 Replies Latest reply on Aug 22, 2016 1:13 AM by Nanaky

    I need to transfer books from my local library to my Nook.?

    fionab38686367

      I want to start from scratch to transfer books to my Nook. They say I have to use ADE 2.0 butI have 4.5. Should that matter?