2 Replies Latest reply on Feb 17, 2009 10:33 AM by El.Ziltcho

    Crossdomain.xml just not working

    El.Ziltcho Level 1
      Hello,

      I am having problems moving my application from my Local Machine to a DEV/TEST server for testing. My app uses C# Web Services for data access and is a Flex front end.

      Here is the error I get (only on the DEV/TEST server):

      A Fault occured contacting the server.
      Fault Message is: HTTP request error
      Faul Code is: Server.Error.Request
      Fault Detail is: Error: [IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #2032: Stream Error. URL: http://DOMAIN/APPLICATION/WebService.asmx" URL: WebService.asmx

      The same exact configuration works on my local machine. I have a crossdomain.xml file in place that looks like this:

      <?xml version="1.0" ?>
      <!DOCTYPE cross-domain-policy (View Source for full doctype...)>
      - <cross-domain-policy>
      <site-control permitted-cross-domain-policies="all" />
      <allow-access-from domain="*" secure="fase" />
      <allow-http-request-headers-from domain="*" headers="*" secure="fase" />
      </cross-domain-policy>

      However, I wouldn't think that the crossdomain is actually necessary because the application exists on the same domain and directory as the webServices. But, I added one anyway because every google lookup seems to say that the HTTP Request Error - Server.Error.Request is a crossdomain.xml problem.

      I was kind of thinking it could be a permission error. However, I have the web page run as an 'application' and that application's user account has permissions to the root directory and all it's children files/directories (so it can read the crossdomain.xml) and also the application idenity has access to run all the selects.

      Unfortunately I'm running this on IIS6 on the DEV/TEST machine and IIS7 on my local machine. So, I'm unable to setup failed request tracing to see if I can find the problem there.

      Does anybody have any help they can share? I've spent the complete day trying everything I can think of to get it to work with no resolve.

      Any help would be greatly appreciated!

      Thanks!!
      -Mike