26 Replies Latest reply on Feb 11, 2009 8:09 AM by valnub

    Unable to embed pdf in AIR application

    valnub
      Hello everyone,

      as the topic already says, I have a problem embeding a pdf into an AIR application using FLEX.

      Instead of the PDF it only shows a dark grey box.
      This probem only occurs under MacOS.
      Using Windows XP, everything works fine.

      I am using the latest versions of Adobe Reader and Acrobat.
      OS is MacOS Leopard 10.5.6 on a Macbook AIR.
      Also tried on a friend's Macbook Pro with Tiger but the result was the same.

      I already checked if the window container may be transparent, since this was the reason for some people on the i-net but for me this didn't work.

      HTMLPDFCapability.ERROR_INSTALLED_READER_NOT_FOUND and HTMLPDFCapability.ERROR_INSTALLED_READER_TOO_OLD don't give me an error, so Adobe Reader's Version seems to be fine.

      I am using the HTMLLoader Component wrapped in an UIComponent.
      Interesting thing here is that rendering HTML Content works fine, but PDF's just won't load.

      Edit: I just tried to capture a screenshot from the program, but the grey box won't show up on the screenshot although it's there in the app.

      I would be really glad if someone could help me with this.

      Here is the code I used: