4 Replies Latest reply on Jun 10, 2017 5:23 AM by jarol-joy

    Cannot open protected PDF in Adobe Reader in iOS

    QuantumBuc Level 1

      Good day. I've spent the last several hours researching this and found several iterations of the problem, but none exactly like it, and no solutions. I'm hoping someone here can help.

       

      We have many PDFs on our website that are protected from editing via password. The PDF does not require a password to open/read, but would if someone tried to edit. We are using Acrobat X compatibility.

       

      On iPads and iPhones, these PDFs cannot be opened. Clicking on one in the browser opens a new page that is blank (gray). If you click on it, the two options are "Open in..." or "Open in 'iBooks'".

      Selecting either option does nothing. The screen stays gray. Some users have reported selecting "Open in iBooks and then being prompted for the password, which is just as unusable.

       

      I have confirmed (via Dropbox) that the Adobe Reader for iOS will read the PDF correctly, but I cannot find any way to get the "Open in" to work for these kind of protected PDFs, but it does work fine for unprotected PDFs.  And this has been reproduced on 4 of 4 iPads/iPhones.

       

      Anyone have ANY suggestions / solutions?

       

      Thanks in advance.

       

      -Elliott

        • 1. Re: Cannot open protected PDF in Adobe Reader in iOS
          Pat Wibbeler Adobe Employee

          Hello,

          If you have Adobe Acrobat iOS installed on your device, tapping "Open In" should present a list of apps that includes "Adobe Acrobat Reader" for opening the file. You may have to swipe the list of apps from right to left to see Adobe Acrobat. If this still does not work, please let me know.

           

          That said, there are some forms of encryption and protected documents that the iOS Adobe Acrobat can read, but cannot edit. If you have a sample of one of these files to share, you can email me at pawibbel@adobe.com and I can confirm.

           

          Thanks!

           

          Pat

          • 2. Re: Cannot open protected PDF in Adobe Reader in iOS
            QuantumBuc Level 1

            Pat,

             

            Thanks for the quick response. The problem is that, for these documents, the "Open In..." dialogue does nothing. When clicking the link for any of these protected documents, a new tab opens in Safari with the Open In... link in the upper left, but clicking the button does nothing, unlike other documents, where the list of apps appears.  The viewer just seems to choke on these protected docs.

             

            I will email you an example at the address you provided.  We are expecting viewer to just view it, not allow editing.  The password protection is for editing, not viewing.

             

            Thanks!

             

            -Elliott

            • 3. Re: Cannot open protected PDF in Adobe Reader in iOS
              Pat Wibbeler Adobe Employee

              Thank you again for reaching out. After seeing your file, I am nearly positive that this is a bug in Safari (since "Open In" does nothing). I will file a bug with Apple.

              • 4. Re: Cannot open protected PDF in Adobe Reader in iOS
                jarol-joy Level 1

                Hi Pat,

                I have a similar problem. I have several pdf documents signed with a self-signed certificate (created by me from Microsoft Internet Information Server).

                 

                 

                I have installed my self-signed certificate in Windows 10 operating system and I open that document without problems. But when I try to open it in Android, IOS (iphone) or Mac OS, I always get the same error: "The file is possible to be damaged or format which Preview View does not be able to recognize" or something like that. I have installed the self-signed certificate in them as well.

                 

                 

                I have tested with diferents certificates and pdf versions (when I convert it from a .docx file) and I always get the same result in Android, IOS and Mac OS.

                 

                 

                What is the problem? What am I doing wrong?

                Regards