6 Replies Latest reply on Jan 30, 2009 2:37 AM by neal2000uk

    Buddy API HELP

    neal2000uk
      I have just downloaded Buddy API for Director 11 (windows) and it is not working for me. I have downloaded the file and place 'Buddy API Help.chm', 'Buddy API Xtra.x32' and 'Read me.txt into 'C:\Program Files\Adobe\Adobe Director 11\Configuration\Xtras'. I have also added #namePPC:"Buddy API Xtra", #nameW32:"Buddy API Xtra.x32" to the bottom of the xtrainfo.txt file.

      I made a new project and named it 'test.dir' and saved this in a filder called 'test' on the desktop. I placed one button on a frame and added the code:

      'on mouseUp me
      baOpenFile( the moviePath & "test.txt" , "normal" )
      end

      I created a text file and named it 'test.txt' and saved this into the test folder on the desktop.

      I then saved a projector of the project into the same folder.

      When I click on the button, nothing happens???? WHAT AM I DOING WRONG?????


        • 1. Re: Buddy API HELP
          Applied CD Level 1
          Make sure you add the Buddy API xtra to the projector. From the top menu navigate to Modify>Movie>Xtras… click the Add button, scroll to budapi.x32, select it and click OK, then remake your projector. If it still doesn’t work, getting the path wrong seems to be the most common mistake with file functions. Your path looks fairly straight forward but it never hurts to check, add a temporary line: alert _movie.moviePath & “test.txt” when you run the projector check the path in the alert box against the actual file location, is Buddy API looking for the file in the right place?
          • 2. Re: Buddy API HELP
            neal2000uk Level 1
            Thanks for the quick reply. Yes i did forget to add the xtra to my projector, however, when i go to Modify>Movie>Xtras, there is no budapi.x32 to select ?????
            • 3. Re: Buddy API HELP
              neal2000uk Level 1
              sorry, i've found the xtra and added it but still no joy :(
              • 4. Re: Buddy API HELP
                Level 7
                In the Modify, Movies, Xtras list, it will likely be called 'Buddy API
                Xtra'.

                When you say that you push the button and "nothing happens". Do you
                mean that literally? Or do you get an error message of some sort? If
                you have not added BuddyAPI into the projector, you should get an error
                stating that baOpenFile is not available (or perhaps a less useful
                "script error").

                If you are not even getting that, then I assume you are using a
                #flashComponent button and you need to go into the Property Inspector's
                Flash Component tab and change the 'eventPassMode' to #passAlways in
                order to make the button work.
                • 5. Re: Buddy API HELP
                  Level 7
                  Also, there are 2 versions of BuddyAPI right now, one that works with
                  D10 and lower and another that only works with D11. Make sure you have
                  the right one installed.
                  • 6. Re: Buddy API HELP
                    neal2000uk Level 1
                    Thanks so much for your help. You were right it was the #flashComponent button that was the problem. When I changed it to pass always it worked fine. Thank again!