4 Replies Latest reply on Jul 12, 2016 10:15 AM by tims14924469

    InDesign CC 2015 crashing my Mac - and crashing hard.

    kphillips345 Level 1

      Hi all,


      I seem to have an issue with InDesign CC 2015 being the only program out of the suite of CC programs I use that seems to crash my Mac HARD when it does every now and then. In the case of it happening just this morning, I had 5 .indd files open, none any larger than 2.5 MB, and was exporting PDFs for each, trying to give some 'space' between exports so that InDesign would not hang and give me the spinning beachball of death. When it did, though, and as it always does, when InDesign's 'background tasks' bar freezes and I get the spinning wheel on Mac that never ever resolves itself, no matter how many times I try to right click or do the keyboard command for Force Quit, InDesign will NOT quit. This crash-in-progress also prevents me from closing any other open programs on my computer, too. So, inevitably I am forced to do a hard reset of my Mac and close every program I have open, which I know can be damaging or run the risk of errors.


      Any idea why only InDesign causes this issue? If I am working with a large file in Illustrator or Photoshop CC 2015, and I am forced to quit or my Mac hangs, I have never ever been able to NOT force quit other programs and have to completely shut down my Mac with no other option. I will get the usual Adobe Crash Report after it crashes, and then I just restart and move on with my life. But InDesign... every time I see that dreaded frozen background tasks bar and the spinning wheel of death, I know I'm in for a good 5-8 minutes of lost productivity due to me having to hard reset everything. Plus, it's frustrating because it resets my workspace and brings up the Welcome screen (which I currently shut off at startup). It crashes it so hard it sets it back to defaults!


      It seems that issue doesn't go away even when I have cleared my startup disk. I'm just not sure why it's InDesign that is so volatile. Any thoughts on preferences or settings I could change to minimize this? Or is this more of a Mac/RAM issue than an Adobe one? Specs on my Mac are as follows, if this helps:


      Mac Pro (Early 2009)

      Running OS X Yosemite

      32 GB 1066 MHz DDR3 ECC