3 Replies Latest reply on Jan 22, 2016 5:34 PM by soundman1963

    InDesign CS6 ePUB and table formatting - Can't get rid of 1pt stroke on border and cells

    soundman1963 Level 1

      I'm new to ePUB and I'm working on a test document that contains 5 pages of text and graphics, which are displaying correctly. However, on page 2, I created a 3 column, 4 row table (plus an extra row defined as a header). I've formatted it using a Table and Cell styles. The table style references a separate cell style for the header and a second style for the body. It also has alternating fills set to every other row. This is exporting properly.

       

      The problem I'm having is, when I export to ePUB, I can't get rid of the 1pt. table border and cell strokes. I've set the table style for both Row Strokes and Column Strokes to None for the Alternating Pattern drop-down list. This grays out all other features, and I noticed the Weight for the stroke is also set to zero. Both cell styles have their Stroke Weight set to zero. There are no strokes visible in my InDesign CS6 document. After I export, I cracked open the ePUB to read the CSS. I noticed there is an entry for the <td> and <th> tags with a stroke set to 1pt. I loaded the page with the table in a browser and then changed the value to 0px. When I refresh the page, the strokes are turned off.

       

      Is this a default value that gets added to the CSS, upon export?

      Is there a way to prevent this from happening in InDesign so I don't have to edit the CSS afterwards?

       

      td, th {

          border-style:solid;

          border-width:1px;

      }

      table {

          border-collapse:collapse;

      }

      table.Table-Four-Rows {

          border-style:none;

          border-width:0px;

          margin-bottom:20px;

          margin-top:20px;

          margin-left:10px;

      }

      td.Table-Header-row {

          background-color:#ff8080;

          padding-bottom:10px;

          padding-left:20px;

          padding-right:10px;

          padding-top:10px;

      }

      td.Table-Body-Row-Spacing {

          padding-bottom:30px;

          padding-left:20px;

          padding-right:30px;

          padding-top:30px;

      }

        • 1. Re: InDesign CS6 ePUB and table formatting - Can't get rid of 1pt stroke on border and cells
          BobLevine MVP & Adobe Community Professional

          You’d be far better off moving to CC which does a far superior job exporting to EPUB. I’ve done them with no need to write any CSS or crack open the EPUB.

           

          With CS6 you’re going to need to do both.

          • 2. Re: InDesign CS6 ePUB and table formatting - Can't get rid of 1pt stroke on border and cells
            Monica Singh Adobe Employee

            Hi Soundman,

             

            The value in td, th is the default value. You should not be concerned with that..

            This value can be overridden by the cell style, cell overrides or by table styles that you have applied on the table in InDesign.

             

            For your case where you want a table with all cell borders=0px.

            I would suggest create a cell style say "zeroborder" with cell border= 0px. Create a table style "T1" with table border=0px and cell style(in table style panel at general pane) "zeroborder".

            Apply this T1 style to the table and you shall have the desired results on export..

             

            Let me know if it works for you..

             

            Regards,

            Monica Singh

            • 3. Re: InDesign CS6 ePUB and table formatting - Can't get rid of 1pt stroke on border and cells
              soundman1963 Level 1

              Thanks for replying. I think the problem is in InDesign CS6. I did try Monica's suggestion, but I still get the 1pt border around the cells and table border when I export to ePUB. Both of my table and cell styles have zero set to the stroke weight. However, if you notice in the CSS I posted, there is no border-width for 3 styles I used (table.Table-Four-Rows, td.Table-Header-row and td.Table-Body-Row-Spacing).

               

              I took Bob's advice today and downloaded the CC 2015 version of InDesign and exported the very same file without making any changes to it. This time, when I exported to ePUB, there were no borders, like I wanted. I've found that tables in CS6 don't always display the settings I'd define in a table or cell style.

               

              A big thanks for both of your suggestions!

               

              -c