4 Replies Latest reply on Jan 28, 2009 5:02 PM by 2JZ

    Tree's node label disappear?

    2JZ
      Guys,

      I have the php returned me a xml data to my tree control. When I expand or collapse a node, one of the children node's label become empty. However, If I maximize the browser, everything is back to normal. I am using Adobe Flex builder 3. Any idea?

      -Alan
        • 1. Re: Tree's node label disappear?
          Level 7

          "2JZ" <webforumsuser@macromedia.com> wrote in message
          news:glqf9j$l9n$1@forums.macromedia.com...
          > Guys,
          >
          > I have the php returned me a xml data to my tree control. When I expand or
          > collapse a node, one of the children node's label become empty. However,
          > If I
          > maximize the browser, everything is back to normal. I am using Adobe Flex
          > builder 3. Any idea?

          Are you using custom itemRenderers? If so, check out Q2
          http://www.magnoliamultimedia.com/flex_examples/Amys_Flex_FAQ.pdf


          • 2. Re: Tree's node label disappear?
            2JZ Level 1
            Amy,

            Here is how I declare teh tree control.

            <mx:Tree id="ViewTreeCtrl" width="100%" height="100%" horizontalScrollPolicy="auto" allowMultipleSelection="true" color="#000000" dataProvider="{ViewXML}" labelField="@name" borderStyle="none" alpha="1.0" selectable="true" iconFunction="TreeIconAssignment" dropEnabled="true" dragEnabled="true" dragDrop="OnViewDragDrop(event)" dragEnter="OnDragEnter(event)">

            I am not sure if I am indirectly using custom itemRenderers. When using these functions:

            labelField="@name"
            iconFunction="TreeIconAssignment"

            Where TreeIconAssignment() specify which embedded icons to use base on the node's type.
            • 3. Re: Tree's node label disappear?
              Level 7

              "2JZ" <webforumsuser@macromedia.com> wrote in message
              news:glqtok$8v5$1@forums.macromedia.com...
              > Amy,
              >
              > Here is how I declare teh tree control.
              >
              > <mx:Tree id="ViewTreeCtrl" width="100%" height="100%"
              > horizontalScrollPolicy="auto" allowMultipleSelection="true"
              > color="#000000"
              > dataProvider="{ViewXML}" labelField="@name" borderStyle="none" alpha="1.0"
              > selectable="true" iconFunction="TreeIconAssignment" dropEnabled="true"
              > dragEnabled="true" dragDrop="OnViewDragDrop(event)"
              > dragEnter="OnDragEnter(event)">
              >
              > I am not sure if I am indirectly using custom itemRenderers. When using
              > these
              > functions:
              >
              > labelField="@name"
              > iconFunction="TreeIconAssignment"
              >
              > Where TreeIconAssignment() specify which embedded icons to use base on
              > the
              > node's type.

              That shouldn't cause the problem. I'm not seeing anything in what you
              posted that would cause the problem. Sorry :-(


              • 4. Re: Tree's node label disappear?
                2JZ Level 1
                I just know that once I resize the browser, everything is back to normal and it won't happen again.