5 Replies Latest reply on Jan 26, 2016 2:46 PM by Tanuj Sandal

    D810 not working with 4.4 Lr, what are my options?

    vouvoune

      From what I can tell, looks like Lr 4.4 isn't compatible with the D810.
      I have Photoshop which I don't use all that much as i find Lr easier to navigate but if I understand Bridge/Camera Raw could be used but I don't know much about it.

      I also just bought a new computer and was going to transfer Lr anyways so should I buy a brand new version or just upgrade somehow, is that even possible?

      It seem pretty lame, I bought that version like 2.5 yrs ago :/