4 Replies Latest reply on Mar 30, 2009 9:15 AM by MergeThis

    MultiLevelList

    Casper Lange Level 1
      With a multilevel list I want to create the following layout:

      1. Level 1
      Level 2
      a. Level 3
      b, Level 3
      Level 4
      c. Level 3
      2. Level 1

      In short: the text immediately below level 1 and 3 has NO numbering, but only has an indent.
      In the edit multilevel style dialog, I apply a numbered style from the stylesheet to level 1 and a non-numbered style to level 2. I even choose List style [none] for level 2.
      When I click OK and open the style again, Level 2 reads upper-alpha. Is this a bug or am I doing something wrong.
        • 1. Re: MultiLevelList
          Casper Lange Level 1
          Does anyone have a solution for this?

          I create a multilevel list style.
          Level 1 is mapped to the style Normal, with a decimal numbering
          Level 2 is mapped to a style named NormalIndent, an indented style. I apply the list style [none] here.
          Click OK and edit the style again.
          Level 2 shows upper-alpha now. RH 8 doesn't seem to save the [none] list style.
          • 2. Re: MultiLevelList
            Captiv8r Adobe Community Professional & MVP
            Hi there

            These beasties are a bit different. After you adjust the styling you then have to apply it to the list to see changes. I don't believe the list just picks it up.

            Have you tried that?

            Cheers... Rick
            • 3. Re: MultiLevelList
              MergeThis Level 4
              Nor is there a GUI method that allows you to switch from inside (the default) to outside. The only way I've found for this is to hit the indent button twice (at the bottom of the window), then go into the css file and adjust the indents (e.g., text-indent: -19px;).

              I've also been testing a method that would allow the use of plain text (or images, etc.) by creating even levels for plain (none) and odd levels for symbols. For example, BulletNumberCircle would have these levels:

              x-lvl-1-type: disc; (Bullet)
              x-lvl-2-format: ""; (the empty double quotes will prevent RH from automatically giving you A,B,C, etc. when you select None)
              x-lvl-3-format: "<x>."; (Number)
              x-lvl-4-format: ""; (see lvl-2)
              x-lvl-5-format: "<x>"; (Circle)
              x-lvl-6-format: ""; (see lvl-2 & lvl-4)

              Although these levels don't strictly mirror the normal step-down for list levels, it does allow for inserting plain paragraphs under each of the main symbol levels. Further testing will be done, but so far it looks good.

              However, I did raise this issue several months ago with the RH developers, so I'm worried about doing too much customization and then have to undo it if they issue a patch to fix this.


              Good luck,
              Leon
              • 4. Re: MultiLevelList
                MergeThis Level 4
                More testing has revealed that each time you close the project and then reopen it, some of your changes to the .css file are randomly messed with by RH, therefore rendering them useless.

                I've just submitted a Bug report for this issue.

                Until RH can provide relief for this, the much-ballyhooed feature is completely useless for the following reasons:

                * The default indent and alignment settings are the opposite of the default settings achieved with the usual list toolbar buttons. These styles are not useful to us, since they would display differently from the thousands of lists already in our projects.

                * The output you get when selecting the "disc" List Style is &#183; - which is actually the tiny "mid-dot", not disc. (The RH 8 filled-circle option, a non-W3C option, is larger and therefore closer to the default disc.)

                * The None option in the List Style control displays upper-alpha list markers (A, B, C, etc.), as stated in the original post.

                * No options are enabled when clicking the Format button (Paragraph for Space after, etc.).


                Good luck,
                Leon