9 Replies Latest reply on Feb 1, 2016 10:35 AM by michaeld15755000

    is lightroom cc 6.4 compatible with mac os 10.8.5?

    michaeld15755000

      I have just installed the latest version of lightroom cc 6.4 and it doesn't seem to be compatible with mac os 10.8.5.

      I have also tried installing the previous version that is available on creative cloud but that isn't compatible with the catalogue I have, which it states comes from a newer version of LR.

      How can I go back to the LR version version before 27th Jan which is when these latest updates seem to have been released?